The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fantastico?

Discussion in 'General Discussion' started by JamesCTotalWeb, Aug 20, 2005.

  1. JamesCTotalWeb

    JamesCTotalWeb Well-Known Member

    Joined:
    Mar 20, 2005
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Well I upgraded cPanel lat night to the newsest Release version and now Fantastico is gone?

    We are using X theme WHM 10.6.0 cPanel 10.6.0-R16

    Anyone else have this problem? Is there and thing I can do to get it back?

    Thanks for the help yall ...... :)

    Well I guess I should do some research before asking for help ..... lol

    The answer is at http://netenberg.com/forum/

    Here is what I did as listed on the site.

    After the last CPanel update, the Fantastico icon disappears from the x and x2 skins: In SSH enter these commands:
    mkdir /usr/local/cpanel/base/frontend/x/cells
    (if you get a "File exists" error just ignore)
    mv /usr/local/cpanel/3rdparty/fantastico/xskin.html /usr/local/cpanel/base/frontend/x/cells/fantastico.html
    (if you get ANY error after this command, please post in the forums)
    ln -s /usr/local/cpanel/base/frontend/x/cells /usr/local/cpanel/base/frontend/x2/cells
    (if you get a "File exists" error just ignore)


    Worked like a charm/.
     
    #1 JamesCTotalWeb, Aug 20, 2005
    Last edited: Aug 21, 2005
  2. Holbrookau

    Holbrookau Active Member

    Joined:
    Aug 23, 2002
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Had the same issue after upping to cPanel 10.5.0-C72.
    Thanks for posting JamesCTotalWeb - saved me some time. ;)
     
  3. Alex_D

    Alex_D Registered

    Joined:
    May 27, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Also you can try to add the following line to your /usr/local/cpanel/base/frontend/x/index.html file:

    <cpanel include="fantastico/xskin.html">

    Add this somewhere in the bottom of index.html. It helped in my case (for x and x2 themes) :)
    If you have rvskins, just try to run "Fantastico Integration" from Rvskin Manager.
     
    #3 Alex_D, Aug 21, 2005
    Last edited: Aug 21, 2005
  4. chae

    chae Well-Known Member

    Joined:
    Apr 19, 2003
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Auckland, New Zealand
    Thanks for the post - just noticed Fantastico had disappeared this morning
     
  5. JamesCTotalWeb

    JamesCTotalWeb Well-Known Member

    Joined:
    Mar 20, 2005
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator

    Yes that would work too Alex_D but I think the work around listed on Fantastico web site is to try and prevent this from happening on the next update. ;)

    Of course I could be wrong ........ lol
     
    #5 JamesCTotalWeb, Aug 21, 2005
    Last edited: Aug 21, 2005
  6. icontact

    icontact Member

    Joined:
    May 25, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Updated to WHM 10.6.0 cPanel 10.6.0-R45 about ten minutes ago and then I saw this post. Fantastico icon did in fact disappear but the fix posted above restored the icon with no problems and no errors encountered so far

    Thanks fo shareing
     
  7. daveh901

    daveh901 Registered

    Joined:
    Jul 9, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Anyone with this problem may also want to locate xskin.html first, as I had a couple of servers where this file was located in a different place. Amend the fix where appropriate.
     
  8. shauvik

    shauvik Member

    Joined:
    Jan 18, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    All connections on server refused !!!


    This worked perfectly.....
    After this..i did a fantastico update...from feature manager..in fantastico admin panel...
    After this the server stopped responding and refuses all web requests (i guess thats port 80)
    But Cpanel login and all is working....

    IN fantastico admin panel it shows me...
    Code:
    Fantastico is not installed at the default location /usr/local/cpanel/3rdparty/fantastico. 
    Either move the Fantastico directory from it's current location to /usr/local/cpanel/3rdparty/fantastico 
    and then load the Fantastico admin panel 
    in order for the config files to be auto-reset 
    OR enableioncube loaders in WHM -> Tweak settings.
    
    please help me...
     
    #8 shauvik, Aug 22, 2005
    Last edited: Aug 23, 2005
  9. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    I ditched the RELEASE version and went to stable without any problems.
     
  10. shauvik

    shauvik Member

    Joined:
    Jan 18, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    APACHE Server failed

    Actual problem identified::

    The Apache server has stopped running and won't even restart....
    "httpd has failed, please contact the sysadmin."
     
  11. `joshua`

    `joshua` Active Member

    Joined:
    Dec 23, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    thanks, JamesCTotalWeb

    thats extactly what mine did.. i updated /scripts/upcp and done those steps you had pasted there.. and fantastico re-appeared.. again thanks!
     

Share This Page