Fast/Cgi was changed on all accounts

ultralion

Well-Known Member
Nov 14, 2012
51
0
6
Viareggio
cPanel Access Level
Root Administrator
Hi,
i was looking on the web if there was a way to set only some account with fast/cgi instead of suphp.
I've seen on simple cpanel hosting there was option to set Apache Handler in advanced configuration.
So i did a try and i added:
Handler: fcgid-script
extension: .php

It worked and phpinfo correctly show me that hosting is running on fast/cgi.
Problem is that all others website now have that handler!!
So i went to see inside Easy Apache and still show me that i'm on Suphp.
How is possible? I should fix this or not? I don't want to do some misconfiguration.
Thanks
 

ultralion

Well-Known Member
Nov 14, 2012
51
0
6
Viareggio
cPanel Access Level
Root Administrator
Note: On that hosting the custom Apache Handler is not present anymore. I suppose that the option must appear under the tab so i could remove... but it isn't. Seems that i changed whole accounts from one :eek:
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

There are no native options that will allow you to configure the PHP handler on a per-account basis. It's only configurable globally. Feel free to open a feature request for this at:

Submit A Feature Request

Thank you.
 

ultralion

Well-Known Member
Nov 14, 2012
51
0
6
Viareggio
cPanel Access Level
Root Administrator
Hello :)

There are no native options that will allow you to configure the PHP handler on a per-account basis. It's only configurable globally. Feel free to open a feature request for this at:

Submit A Feature Request

Thank you.
Yes i understood that, but how is possible that changing in Apache advanced configuration (Cpanel User/account side) default handler changed from suphp to fast-cgi on all websites?
Also i still see in admin control panel that default handler is suphp
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
It's only changed through Web Host Manager via:

"WHM Home » Service Configuration » Configure PHP and suEXEC"

Thank you.
 

ultralion

Well-Known Member
Nov 14, 2012
51
0
6
Viareggio
cPanel Access Level
Root Administrator
I still can't understand. I know that in "WHM Home » Service Configuration » Configure PHP and suEXEC" is possible to change handler.
I don't realize why on Cpanel account (not WHM but simply user interface) in:
Advanced Configuration---> Apache Handler i added:
Handler: fcgid-script
extension: .php
And Server Api details has changed from suphp to Cgi-Fastgi on that hosting account and all the others.
I didn't touch my settings in WHM

This is a php info from other hosting
fastcgi.png
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
I have not been able to reproduce that issue. If you are able to reproduce it, please open a bug report via:

Submit A Bug Report

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

ultralion

Well-Known Member
Nov 14, 2012
51
0
6
Viareggio
cPanel Access Level
Root Administrator
Of course i'll do it. Anyway i feel confused now.
You wrote:
There are no native options that will allow you to configure the PHP handler on a per-account basis
But so why an user should have this panel on his interface? :confused:
handler.png

I did it from here
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Apache handlers are not the same thing as PHP handlers. Apache handlers control how your site’s Apache web server software manages certain file types and file extensions. PHP handlers deliver the PHP programming libraries. You can review the documentation for each at:

Apache Handlers
PHP Handlers

Thank you.
 

ultralion

Well-Known Member
Nov 14, 2012
51
0
6
Viareggio
cPanel Access Level
Root Administrator
Ok i see... in fact i tried to give a 777 permission to an account public_html and it crashed :D
I know that php fast-cgi this could not happen... so i suppose i'm running suphp ;)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Ok i see... in fact i tried to give a 777 permission to an account public_html and it crashed :D I know that php fast-cgi this could not happen... so i suppose i'm running suphp
That is correct. It's not possible to modify the PHP handler from the cPanel interface.

Thank you.
 

ultralion

Well-Known Member
Nov 14, 2012
51
0
6
Viareggio
cPanel Access Level
Root Administrator
Yes i'm a stupid man sorry :(
For some strange cause my brain was thinking "server api= php handler" and i was thinking it showed "suphp" but no way... also when a server is on SUPHP ever show CGI/FastGgi Server Api. In fact i'm running correctly on suphp
I apologize... i'm newbie