fastcgi ignores display_errors = Off

Nash1

Member
Oct 20, 2015
8
0
1
San Diego
cPanel Access Level
Root Administrator
Hello All,

I am running WHM 11.52 with EA3 using fastcgi and PHP 5.6. When I use WHM > PHP Configuration Editor > Advanced to set display_errors = Off, nothing happens. The setting is ignored. PHP warnings still appear on the web pages. Even restarting Apache and killing off all php processes doesn't help.

If I put a .user.ini in the public_html of the account that contains:
display_errors = Off
error_reporting = 0

Then the PHP warnings go away. How can I set display_errors = Off for all sites in WHM? Also worth noting, log_errors = On, fails to log the PHP warnings to the Apache error_log.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
I am running WHM 11.52 with EA3 using fastcgi and PHP 5.6. When I use WHM > PHP Configuration Editor > Advanced to set display_errors = Off, nothing happens.
Hello :)

Could you verify if this is only happening when using FCGI as your handler?

Thank you.
 

Nash1

Member
Oct 20, 2015
8
0
1
San Diego
cPanel Access Level
Root Administrator
I'm running a production environment with over 150 domains. How can I test that without breaking things? I do not want to change the FCGI handler for all of the domains.

-Ron
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Could you check to see if there are any .htaccess files in the document root of the domain name that could be adjusting this option on an account-level? Also, if you upload a PHPINFO file in the same directory, does it show the correct value?

Thank you.