The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

fastcgi / internal 500's after php upgrade

Discussion in 'General Discussion' started by NoAgendas, Aug 20, 2006.

  1. NoAgendas

    NoAgendas Guest

    I get internal 500 errors on one particular server after going from php 4.4.2 to 4.4.4 (all modules the same except newer php version)

    apache log:

    Premature end of script headers

    (all php based sites)

    What is the fix for this?

    Another problem with fastcgi:

    /etc/rc.d/init.d/httpd restart: httpd not running, trying to start
    Syntax error on line 193 of /usr/local/apache/conf/httpd.conf:
    FastCgiIpcDir /tmp/fcgi_ipc: access for server (uid -1, gid -1) failed: write not allowed

    phpsuexec enabled / centos 4.3 / cpanel 10x stable

    I ran the below as well, didn't fix it.

    /scripts/chownpublichtmls
    find /home -perm 755 -type d
    find /home -perm 755 -type f
    find /home -perm 755 -exec chmod 755 {} \;

    The odd part is I have two other servers 100% identcial literally (o/s, cpanel, modules, etc) and it upgraded fine.

    Modules:

    Expires Module
    Raise FD_SETSIZE to 16384 (System Wide)
    Prevent Users from reading other webroots Frontpage Module

    Raise HARD_SERVER_LIMIT

    Php Module Version 4.4.4

    Bc Math
    Calendar Support
    Curl (Version 7.15.3)
    Curl SSL Support (Version 2.8.28)
    Dom XSLT
    Exif
    Flash
    FTP
    GD (Version 2.0.15)
    GetText
    Iconv (experimental)
    Imap Module (Version 2004g)
    Mb String
    Mcrypt (Version 2.5.7)
    Mhash (Version 0.8.18)
    Magic Quotes
    MM Session Module (Version 1.3.1)
    Mysql Module
    SNMP
    Openssl Support
    Discard Path
    PDFlib
    Pear
    Postgresql (will break 7.2.x or earlier, please make sure you have 7.3.x or later installed) Pspell Module Sockets Use System Mysql Track Vars Freetype Support Zip Zlib PHP suEXEC Support Rewrite Module SSL Module (Version 2.8.28) suEXEC Module
     
  2. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    I am having this same issue. It appears to be related to php suexec. As soon as it is disabled everything works great. We have been using php suexec for quite some time with no problems. I have checked .htaccess files, ownership, php permissions etc and they are all fine. These sites works great until the update to PHP 4.4.4 from 4.4.2. Nothing else in the easyapache config was changed.
     
  3. JaCE

    JaCE Member

    Joined:
    Aug 25, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    try a

    httpd configtest

    see if that will output your real problem. i know w/ mine i get alot of errors bout * w/ ports but ive had those for years w/ out a issue.

    good luck
     
  4. NoAgendas

    NoAgendas Guest

    httpd configtest shows no errors

    Anyone else know about this?
     
  5. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
  6. NightStorm

    NightStorm Well-Known Member

    Joined:
    Jul 28, 2003
    Messages:
    286
    Likes Received:
    4
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Same problem here. I had Michael from cPanel on the server last night trying to figure out what was wrong, and he came up empty. We knew there was something wrong, and I figured out what was causing it, but we could not figure out why.
    I ended up rolling back to 4.4.3.
     
  7. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    I don't think it has anything to do with PHP ....

    I have machines all over the place that are going down with the same problem
    with Cpanel tonight and none of them have had any updates or changes
    to PHP lately and none of them are running phpsuexec or suphp.

    It looks more like a file / directory permission problem in the latest cpanel update
     
  8. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    The latest cpanel update added the following to my httpd.conf file:

    <IfModule mod_suphp.c>
    suPHP_Engine on
    suPHP_ConfigPath /opt/suphp_php_bin
    suPHP_AddHandler x-httpd-php
    <Directory /home*/*/public_html>
    suPHP_AddHandler x-httpd-php
    </Directory>
    AddHandler x-httpd-php .php .php3 .php4 .phtml
    AddType application/x-httpd-php .php .phtml .php3 .php4
    </IfModule>
    <IfModule !mod_suphp.c>
    AddHandler x-httpd-php .php .php3 .php4 .phtml
    AddType application/x-httpd-php .php .phtml .php3 .php4
    </IfModule>
    <VirtualHost *>

    This was a /scripts/upcp Release update, not easyapache. It killed php on the server. After hunting this down and removing it php was re-enabled. I don't quite understand why it would cause so much trouble. I don't have mod_suphp or phpsuexec installed.
     
  9. NoAgendas

    NoAgendas Guest

    That's not true in my case. I get premature script header errors only when upgrading to php 4.4.3 or 4.4.4
     
  10. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam

    If you are using the new easyapache (edge), then you must checked the follow options under php:

    enable cgi
    enable-cgi-force-redirect
     
  11. NoAgendas

    NoAgendas Guest

    I do not understand. Is this in httpd.conf? Where? I'm using whm apache update, release version of cpanel
     
    #11 NoAgendas, Sep 2, 2006
    Last edited by a moderator: Sep 2, 2006
  12. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam

    When you run easyapache (edge) :);)
     
    #12 rachweb, Sep 2, 2006
    Last edited: Sep 2, 2006
  13. NoAgendas

    NoAgendas Guest

    That means I have to upgrade cpanel to edge?

    Isn't there a better way than that?
     
  14. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    The easyapache on release/stable/current is installing php as cli version. There are howtos on the internet how you can change this to cgi version.

    The easyapache on edge has the options for cgi version and suphp option. But the httpd.conf is not finished yet for the new easyapache. See bugzilla http://bugzilla.cpanel.net/show_bug.cgi?id=4526 and http://bugzilla.cpanel.net/show_bug.cgi?id=2299 for more information.

    Suphp/fastcgi requires cgi version to work correctly
     
Loading...

Share This Page