Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Fatal error: Class 'OAuth' not found - Magento REST API (Install Oauth)

Discussion in 'General Discussion' started by Ivo Danic, Jan 27, 2016.

  1. Ivo Danic

    Ivo Danic Active Member

    Joined:
    Dec 1, 2015
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    México
    cPanel Access Level:
    Root Administrator
    Im trying to use the magento rest api, but when i load a simple script (php) apears an error, that says: "Fatal error: Class 'OAuth' not found" So i try to install the extension but when i run "pecl install oauth" the following message apears ->

    Code:
    pecl/oauth requires PHP (version >= 7.0.0), installed version is 5.5.31
    No valid packages found
    install failed
    The oauth.so object is not in /usr/local/lib/php/extensions/no-debug-non-zts-20121212
    Tidying /usr/local/lib/php.ini...
    No changes
    Tidying /usr/local/cpanel/3rdparty/php/54/etc/php.ini...
    No changes
    Thanks for the help! : )
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can install the older version that supports PHP 5.5 via the following command:

    Code:
    pecl install https://pecl.php.net/get/oauth-1.2.3.tgz
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Ivo Danic

    Ivo Danic Active Member

    Joined:
    Dec 1, 2015
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    México
    cPanel Access Level:
    Root Administrator
    I tryed again and these are the results... (the image)
     

    Attached Files:

  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Check to see if the issue persists after installing the "pcre-devel" package:

    Code:
    yum install pcre-devel
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Ivo Danic

    Ivo Danic Active Member

    Joined:
    Dec 1, 2015
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    México
    cPanel Access Level:
    Root Administrator
    It Works !! Thanks!!!
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I am happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice