The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fatal error: Out of memory in cpanel horde

Discussion in 'General Discussion' started by johnburk, Mar 22, 2012.

  1. johnburk

    johnburk Well-Known Member

    Joined:
    Jun 23, 2006
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    When trying to open an attachement I get the following error in the cPanel horde webmail.

    Code:
    Fatal error: Out of memory (allocated 46399488) (tried to allocate 17309701 bytes) in /usr/local/cpanel/base/horde/lib/Horde/MIME/Part.php on line 1157
    This is strange because the allocated memory according to this error is 45M and the file is 17M. Does anyone know why this happens and if it something that can be fixed within cPanel/WHM?

    The php.ini limit is set to 256M

    and
    Code:
    grep -i rlimit /usr/local/apache/conf/httpd.conf
    shows 512

    Solution
    If you have had this problem, then most forums will tell you to look at php.ini of httpd.conf, but that does not solve the problem in this case.

    WHM -> Tweak Settings > The maximum memory a cPanel process can use before it is killed off.

    Default is 256M and you can set it to a higher value. This is the solution.
     
    #1 johnburk, Mar 22, 2012
    Last edited: Mar 22, 2012
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    What did you change it to that worked for you?
     
  3. johnburk

    johnburk Well-Known Member

    Joined:
    Jun 23, 2006
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    WHM -> Tweak Settings > The maximum memory a cPanel process can use before it is killed off.

    Default is 256M and you can set it to a higher value. This is the solution.

    In my case I set it so 512M and that did the job.
     
  4. StarbuckII

    StarbuckII Member

    Joined:
    Nov 13, 2009
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I don't have this is Horde what ever that is but I get a similar error uploading plugins to wordpress blogs hosted under cPanel. It would seem to me that the errors are the same. I increased the process limit to 512, but that didn't solve it. So I have to stop & restart something?

    Am I dealing with the same error issue or is mine different?
     
  5. StarbuckII

    StarbuckII Member

    Joined:
    Nov 13, 2009
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    It obviously restarted a number of Daemons when I selected save changes, but I still get the error.
     
  6. johnburk

    johnburk Well-Known Member

    Joined:
    Jun 23, 2006
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    Make sure your php.ini memory limit is also 512M
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Individual cPAddon installations such as WordPress (those installed using cPanel > Site Software) are bound by either the global php.ini at /usr/local/lib/php.ini or the account's individual php.ini (/home/username/public_html or /home/username/public_html/wordpressfoldername). These do not use the same php.ini as the webmail programs, since webmail is bound by the cPanel process memory limits instead. This means that increasing the Tweak Setting mentioned wouldn't work for WordPress hitting a limit.
     
Loading...

Share This Page