Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

Discussion in 'General Discussion' started by goldclub, Dec 3, 2005.

  1. goldclub

    goldclub Member

    Joined:
    Nov 20, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    oscart login gives me this error FATAL ERROR: register_globals is disabled in php.ini, please enable it! What in the root cpanel do I go to to enable register_globals. Please be detailed!
    Thanks Tony
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    ssh to the server ...
    edit the php.ini and change it to On...

    Very simple
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    166
    If you donot have access to the php.ini, then you can do it for your account by adding the following line in the .htaccess file:

    php_flag register_globals on

    If you want it for some specific application in some folder then do not put this in the .htaccess placed in public_html folder rather create a .htaccess file in that specific folder and add above line in it.
     
  4. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. simplestar

    simplestar Well-Known Member

    Joined:
    Nov 15, 2005
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    156
  6. WCrooks

    WCrooks Active Member

    Joined:
    Aug 29, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Canada
    It's worth noting that the register_globals flag, when set in .htaccess, will not affect it. Setting it will do nothing.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. openmixs

    openmixs Member

    Joined:
    Jan 22, 2006
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    help

    i have this same problem as well
    i need to change it to on
    i am ok with ssh but not that good
    will some 1 walk me through it step by step
    i would be in your debt
    thanks if you can help me ;)
     
  8. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    Login as root :

    ]# pico /usr/lib/php.ini OR nano /usr/lib/php.ini
    Press clt + w and type register_globals
    change it to On to look like
    register_globals = On
    Press Clt + o to save
    Press Clt + x to exit
    ]# /etc/init.d/httpd restart
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice