Fatal Error when trying to edit Contact

parisi

Member
Nov 6, 2006
9
0
151
I am migrating to a new server and succesfully copied all the accounts over. I was updating all of the contacts via the WHM List Accounts interface. All but two worked perfectly.

Two of them had the following error when I clicked the Save Email button:

[a fatal error or timeout occurred while processing this directive]The contact email has been changed to [email protected].

Any ideas? I did check the directory and the .contactemail file was 0 bytes and the contactinfo file in .cpanel folder was also 0 bytes. I copied files from an account that works and still have the same issue. I also checked the ownership and rights and they seem to be appropriate.

Additionally, my List Accounts display has

<div id

where the email should be for the two problem accounts!

Thanks in advance!
Paul.
 

Attachments

cPanelCory

Release Manager - EasyApache
Staff member
Jan 18, 2008
75
10
133
Houston
cPanel Access Level
Root Administrator
What version of WHM/cPanel are you using?
 

parisi

Member
Nov 6, 2006
9
0
151
Version

WHM 11.15.0 cPanel 11.18.6-R24255, CENTOS Enterprise 5 i686 on standard - WHM X v3.1.0
 

n3tph4t

Active Member
Jan 31, 2004
39
0
156
I am migrating to a new server and succesfully copied all the accounts over. I was updating all of the contacts via the WHM List Accounts interface. All but two worked perfectly.

Two of them had the following error when I clicked the Save Email button:

[a fatal error or timeout occurred while processing this directive]The contact email has been changed to [email protected].

Any ideas? I did check the directory and the .contactemail file was 0 bytes and the contactinfo file in .cpanel folder was also 0 bytes. I copied files from an account that works and still have the same issue. I also checked the ownership and rights and they seem to be appropriate.

Additionally, my List Accounts display has

<div id

where the email should be for the two problem accounts!

Thanks in advance!
Paul.
I have it too for one account. I'm not logged in at the moment, I'll post some more specific details later.
 

soif

Member
Jun 7, 2003
12
0
151
Paris
I've got exactly the same problem here.

I guess this happened when I changed an email using the "auto suggest popup" (from Safari)

Did someone found a solution to fix accounts having a bogus contact email ?
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
80
458
cPanel Access Level
Root Administrator
I've got exactly the same problem here.

I guess this happened when I changed an email using the "auto suggest popup" (from Safari)

Did someone found a solution to fix accounts having a bogus contact email ?
Could you provide an example of a bogus contact email?
 

soif

Member
Jun 7, 2003
12
0
151
Paris
Hi kenneth

Thanks for your reply.

After my post i just upgraded to WHM 11.24.2. and this fixed the issue:

I tried to change the contact email that was showing "<div id", and got the
"[a fatal error or timeout occurred while processing this directive]The contact email has been changed to [email protected]. " message.

But this time, the contact email has been successfully updated. :cool:

Thank you cPanel team! :p
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
80
458
cPanel Access Level
Root Administrator
Hi kenneth

Thanks for your reply.

After my post i just upgraded to WHM 11.24.2. and this fixed the issue:

I tried to change the contact email that was showing "<div id", and got the
"[a fatal error or timeout occurred while processing this directive]The contact email has been changed to [email protected]. " message.

But this time, the contact email has been successfully updated. :cool:

Thank you cPanel team! :p
I am glad it is sorted for you. If anyone is still able to duplicate this behavior in 11.24 I would be most interested in sample data for testing purposes. Thank you.
 

servmap

Member
Apr 24, 2006
5
0
151
Already running cPanel 11.24.4-R32603 - WHM 11.24.2 - X 3.9, the problem persist. Clicking on the error message (a fatal error...) gave me this

Code:
Can't use an undefined value as an ARRAY reference at /usr/lib/perl5/site_perl/5.6.2/x86_64-linux/YAML/Syck.pm line 72.
	YAML::Syck::Load(undef) called at /usr/local/cpanel/Cpanel/DataStore.pm line 66
	eval {...} called at /usr/local/cpanel/Cpanel/DataStore.pm line 48
	Cpanel::DataStore::load_ref('/home/--username--/.cpanel/contactinfo', 'HASH(0x47f6210)') called at /usr/local/cpanel/Cpanel/DataStore.pm line 36
	Cpanel::DataStore::fetch_ref('/home/--username--/.cpanel/contactinfo') called at /usr/local/cpanel/Cpanel/CustInfo/Save.pm line 43
	Cpanel::CustInfo::Save::_savecontactinfo('/home/--username--', 1, 'email', '[email protected]') called at whostmgr/bin/whostmgr2.pl line 11999
	main::dochangeemail() called at whostmgr/bin/whostmgr2.pl line 792
(I changed the --username-- and [email protected] part)

installing YAML::Loader:: Syck doesn't help

Please advice