DeepM

Registered
Feb 5, 2007
3
0
151
Got server with apache2.x php5.2.6+php4.4.8 on fcgi, by default worked php5 on fcgi, but if user added to sites .htaccess :

AddHandler fcgid-script .php
FCGIWrapper /usr/local/cpanel/cgi-sys/php4 .php

site starts runing on php4.

But yesterday using EasyApache updated to php5.2.9 and php4.4.9.
After update if sites .htaccess has

AddHandler fcgid-script .php
FCGIWrapper /usr/local/cpanel/cgi-sys/php4 .php
or

AddHandler fcgid-script .php
FCGIWrapper /usr/local/cpanel/cgi-sys/php5 .php

site won't work

in /etc/httpd/logs/error_log got:
/home/a/public_html/.htaccess: FCGIWrapper not allowed here

if add these two lines to lines directli to /etc/httpd/conf/httpd.conf site's viertual host, php version changes correctly

if no .htaccess php5 uses fcgi and works correctly.

Does any body know how to fix that users would can again change php version using .htaccess?
 

DeepM

Registered
Feb 5, 2007
3
0
151
FCGIWrapper seems to no longer be allowed in .htaccess files in the latest
mod_fastcgi/mod_fcgid builds.

:mad: