Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Fcntl.pl

Discussion in 'General Discussion' started by zex, Mar 6, 2002.

  1. zex

    zex Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    306
    cPanel Access Level:
    Root Administrator
    Neomail is not working, he is trying to find modeule called Fcntl.pl.
    I was trying to find that module on 'google' but all that find out is that module Fcntl.pl pl is comming with perl5.6.1,
    I have installed perl5.6.1 from cpanel and can't nowhere find that file.
    Does anybody have this problem?

    Here is error.

    Software error:
    Can't locate Fcntl.pm in @INC (@INC contains: /usr/lib/perl5/5.6.1/i686-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i686-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl /var/cpanel/neomail /usr/local/cpanel/etc) at /usr/local/cpanel/base/neomail/neomail.pl line 32.
    BEGIN failed--compilation aborted at /usr/local/cpanel/base/neomail/neomail.pl line 32.

    For help, please send mail to this site's webmaster, giving this error message and the time and date of the error.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    316
    It's definitely part of the perl hierarchy on these machines....

    /usr/lib/perl5/5.6.0/i386-linux/Fcntl.pm
    /usr/lib/perl5/5.6.0/i386-linux/auto/Fcntl
    /usr/lib/perl5/5.6.0/i386-linux/auto/Fcntl/Fcntl.bs
    /usr/lib/perl5/5.6.0/i386-linux/auto/Fcntl/Fcntl.so
    /usr/lib/perl5/5.6.1/i686-linux/Fcntl.pm
    /usr/lib/perl5/5.6.1/i686-linux/auto/Fcntl
    /usr/lib/perl5/5.6.1/i686-linux/auto/Fcntl/Fcntl.so
    /usr/lib/perl5/5.6.1/i686-linux/auto/Fcntl/Fcntl.bs



    Try /scripts/cleanmd5
    And/or grab the perl installer from layer1 and see if that cleans it up.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice