feature request and info: problem when "skip-name-resolve = 1" is set

bejbi

Well-Known Member
PartnerNOC
Jan 20, 2006
162
30
178
Poland
cPanel Access Level
DataCenter Provider
When you need speed up MySQL and would like to set in /etc/my.cnf: skip-name-resolve = 1

You will experince the problem with some websites, where users set in his configs, database host: "127.0.0.1" but not "localhost"
It should be always set: localhost and then works correctly

Walkaround:
WHM -> SQL Services -> Additional MySQL Access Host -> you can add 127.0.0.1
and then rebuild hosts (link "click here")

But I think cPanel should add this host by default (127.0.0.1 is just default host) - mybe it should be features request ?

:wq
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
1,045
112
118
Houston, TX
cPanel Access Level
Root Administrator
Hello! While I don't believe "localhost" should be unusable, we wouldn't recommend using the "skip-name-resolve" setting.


Warning:
Do not use the skip-name-resolve setting in your server’s MySQL® configuration. This setting will cause serious issues with server operations. If you are not an advanced MySQL administrator, expect issues with this setting. For example, you will see issues with restoring backups. This setting will also cause issues with phpMyAdmin.