The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fed up with automatic cpanel email changes

Discussion in 'E-mail Discussions' started by meeven, Jun 23, 2009.

  1. meeven

    meeven Well-Known Member

    Joined:
    May 8, 2007
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    I have clients who host their email remotely (GoogleApps, other providers). cPanel/WHM just doesn't respect the entries in /etc/remotedomains/ and keeps moving these domains to /etc/localdomains, resulting in clients losing their emails.

    This has happened so many times that customers are getting really irate and I am left tearing my hair out.

    What on earth should I do to prevent cPanel from moving entries around like that?
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Try checking the following:
    - MX Entries are stored in the cPanel account for the remote mail provider
    - "Always accept mail locally even if the primary mx does not point to this server" is unchecked

    There is also a tweak setting "Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed" but as long as the MX is pointed to a remote domain (e.g. something.googlemail.com) rather than the domain itself (e.g. mx1.example.com) this should be functioning correctly.

    If everything looks okay but these issues persist, I recommend letting our technical analysts take a look at things to see what is causing this issue: http://tickets.cPanel.net/submit
     
  3. meeven

    meeven Well-Known Member

    Joined:
    May 8, 2007
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    The cPanel account has the MX entries for the remote mail provider stored correctly, so I checked the 'Always accept mail...' checkbox and found it to be checked.

    Now, the curious thing is that, even when I uncheck it and click the 'Save' button, when I go back to Edit DNS Zone and select that domain, the checkbox shows as ticked.

    Could this be causing the issue?
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I spoke with one of our technical analysts. They actually recommended turning off the "Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed" Tweak Setting and seeing if that resolves this issue.
     
  5. meeven

    meeven Well-Known Member

    Joined:
    May 8, 2007
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Thank you.

    I checked and found that it is actually turned off in both the VPS systems where I am having this problem. The strange thing is that, in one VPS, I see the "Always accept mail locally even if the primary mx does not point to this server" checkbox when editing the DNS zone, but in the other VPS, I do not.

    Should I submit a trouble ticket with cPanel?
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Please do submit a ticket: http://tickets.cpanel.net/submit - if this is a bug in the software, submitting a ticket will allow us to determine the cause of this more swiftly.
     
Loading...

Share This Page