The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

fedora 2 fresh install with cpanel. exim & imap RED.

Discussion in 'General Discussion' started by aboyz, Aug 11, 2004.

  1. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    I did a fresh install on fedora 2 + cpanel. was wondering why i get exim and imap RED mark on my cpanel. I did a restart on the exim and it says started ok. but imap gave me errror. how do i reinstall this or fix this..

    why is it showin RED. i also did a chkservd.

    thanks
     
  2. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    reinstall

    reinstall

    /exim4


    ran ok

    /restartsrv exim
    Waiting for exim to restart..............finished.

    mailnull 1875 0.0 0.4 7720 4628 ? S 11:24 0:00 /usr/bin/perl /usr/local/cpanel/bin/eximstats
    root 3569 0.0 0.1 6988 1560 ? S 11:37 0:00 antirelayd
    root 3578 6.6 2.0 26884 20924 ? S 11:37 0:00 /usr/bin/spamd -d

    exim started ok
    root@cp [/scripts]# chkservd
    root@cp [/scripts]# ./restartsrv imap
    Waiting for inetd to restart..............finished.

    root 3815 0.0 0.0 3744 816 ? S 11:40 0:00 xinetd -stayalive -pidfile /var/run/xinetd.pid

    inetd has failed, please contact the sysadmin.


    i still get red light on WHM why??

    i did a chkservd already

    why is imap fail how do i trace it down or tack it down

    thx
     
  3. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    The most common reason i've come accross for this is that the service are not set to start at boot up. If you have a look through ntsysv or make the appropriate changes via chkconfig, you should be sorted.

    The red dot doesn't go away untill the next time chkservd does a run which i believe is every 9 minutes.

    As far as xinitd, get your distributor to have a look, its probably a simple fubared fix.
     
  4. Seixas

    Seixas Registered

    Joined:
    Sep 8, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem. How to resolve this?
     
  5. azrael

    azrael Active Member

    Joined:
    Jul 20, 2003
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Me too

    I have same problem.....
     
  6. Alexandre

    Alexandre Member
    PartnerNOC

    Joined:
    Jan 21, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    U.S.A.
    The same thing

    /scripts/restartsrv imap
    Waiting for inetd to restart..............finished.

    root 22382 0.1 0.0 2128 776 ? S< 09:42 0:00 xinetd -stayalive -pidfile /var/run/xinetd.pid

    inetd has failed, please contact the sysadmin.
    :) :eek: :eek: :eek: :eek:
     
  7. azrael

    azrael Active Member

    Joined:
    Jul 20, 2003
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    solved

    run /scripts/upcp --force
     
  8. seanstoner

    seanstoner Member

    Joined:
    Nov 1, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    me too

    I hate to post a me too, but . . . .

    :rolleyes:
     
  9. seanstoner

    seanstoner Member

    Joined:
    Nov 1, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    i solved it a different way

    In my case, I had to alter the /etc/xinetd.d/imap file to show the full path of imap; see below. I do find it curious that my imapd was in such a wierd directory and not /sbin or /usr/sbin or more normal location. Anyone care to comment? At least they could have put a symlink in the usual place in the $PATH. What does upcp do in the example you provide?

    Code:
    service imap
    {
            socket_type             = stream
            protocol                = tcp
            wait                    = no
            user                    = root
            server                  = /usr/local/cpanel/3rdparty/bin/imapd
            disable                 = no
    }
    


     
  10. WebTrooper

    WebTrooper Member

    Joined:
    Nov 7, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    I found this thread searching for the same. Running "/scripts/upcp --force" worked for me. Thanks azrael :D
     
Loading...

Share This Page