The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ffmpeg failed

Discussion in 'General Discussion' started by dexjul, Oct 3, 2007.

  1. dexjul

    dexjul Active Member

    Joined:
    Apr 24, 2006
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I having a problem running ffmpeg.

    I run this

    /usr/local/bin/ffmpeg -i '/home/user/public_html/ffmpeg/video.3gp' -an -ss '00:00:01' -t '00:00:01' -r '1' -vframes '1' /home/user/public_html/ffmpeg/video-%d.jpg
    FFmpeg version SVN-r10625, Copyright (c) 2000-2007 Fabrice Bellard, et al.
    configuration: --enable-libmp3lame --enable-libogg --enable-libvorbis --disable-mmx --enable-shared
    libavutil version: 49.5.0
    libavcodec version: 51.44.0
    libavformat version: 51.14.0
    built on Sep 30 2007 05:35:39, gcc: 3.4.6 20060404 (Red Hat 3.4.6-8)
    Segmentation fault (core dumped)

    Any idea about this.

    Thank you
     
  2. shiv

    shiv Member

    Joined:
    Jul 26, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bangalore
    I'm running ffmpeg with following configuration options

    --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr


    recompile ffmpeg and then try running. Also ensure you have the write permissions for ffmpeg binary.
     
  3. cpane1

    cpane1 Well-Known Member

    Joined:
    Jun 10, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
  4. dexjul

    dexjul Active Member

    Joined:
    Apr 24, 2006
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for reply,

    Still having a problem, i re-install ffmpeg. When I ffmpeg I got this error.

    Segmentation fault (core dumped)

    Any idea about this.

    Thanks
     
  5. cpane1

    cpane1 Well-Known Member

    Joined:
    Jun 10, 2007
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    when you use ffmpeg, and the error message comes up.... Segmentation fault (core dumped)
    do you get any core files created on the same directory ? like core.12345 etc ?

    If this is the case then better update you perl modules and your zend optimizer, if you have php 5.2.2 and Versioning enabled with zend 3.2.2 then... do the following...

    /scripts/checkperlmodules

    /scripts/installzendopt 3.3.0

    apache update and remove 'Versioning'

    see if that helps...

    my doubt is still the file that you are using with ffmpeg....
     
  6. dexjul

    dexjul Active Member

    Joined:
    Apr 24, 2006
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Thanks but still the problem

    I get this file -rw------- 1 root root 3928064 Oct 2 21:20 core in the same directory.

    Zend Optimizer v3.3.0 is already updated, perl modules, and versioning is already disable.

    Thanks
     
  7. dexjul

    dexjul Active Member

    Joined:
    Apr 24, 2006
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Its fixed. Thanks
     
Loading...

Share This Page