Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

file error - menu/root.tmpl: not found

Discussion in 'General Discussion' started by DennisMidjord, Jan 24, 2017.

  1. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    96
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    We encountered this error recently. We were trying to move an account from one server to the other, but the process stalled at 25% for hours. Retrying did nothing, but I could see that databases and files had been imported. I deleted the databases manually and removed the /home/userdir folder, and right after deleting the userdir, I started getting the following error: file error - menu/root.tmpl: not found

    I'm not able to create a ticket because I can't see the support access id.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you elaborate on where you are receiving this error message? Did you try transferring the account again after the failed attempt?

    Thank you.
     
  3. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    96
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    I was seeing the issue in WHM. I tried forcing an update, but didn't resolve the issue. I got in contact with support, and Newton was able to fix it, just by forcing an update... No idea why it didn't work when I did it.
    He fixed everything, so consider this case solved! I'm just curious as to what could cause the files for WHM to suddenly dissappear.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It's possible a previous update failed to complete, or files were missing on the system, and thus the additional update corrected the issue. I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
  5. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    96
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    It did indeed solve the issue on WHM, but Softaculous, ConfigServer, Let's Encrypt, Litespeed - basically all our plugins - are missing. When accessing them through WHM, we see a 404 error. Now, how this has happened, I have no idea...
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you let us know of any error output in /usr/local/cpanel/logs/error_log when accessing these plugins?

    Thank you.
     
  7. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    96
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    I don't see any output at all when accessing them.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    This isn't something I'm able to reproduce on a test system. Could you open a new support ticket and post the ticket number here so we can see what's happening?

    Thank you.
     
  9. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    96
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    We already have an on-going ticket with ID #8155593
     
    #9 DennisMidjord, Jan 26, 2017
    Last edited by a moderator: Jan 27, 2017
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Could you verify if reinstalling these plugins corrects the issue?

    Thank you.
     
  11. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    96
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    It didn't solve the issue. Installing Let's Encrypt still gives a 404 error.
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page