The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

File Manager - UTF-8 Encoding

Discussion in 'General Discussion' started by itechdev, Mar 8, 2008.

  1. itechdev

    itechdev Member

    Joined:
    Feb 6, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sunshine Coast - Australia
    Hi there,

    My clients are having problems with the File Manager in cPanel. When editing a file, this notice is received:

    "We have attempted to auto-detect the encoding of this file. However, this is not a foolproof process since some files will display properly with multiple different encodings. You should select the encoding that this file was originally created with. It is very important that you select the proper encoding; saving your file with the wrong encoding may result in the corruption of your text. If you are only using a Western European language like English, Spanish or French without any special characters you can safely assume "ISO-8859-1" will work just fine. If you are using a non-western language or you have special characters that are not HTML encoded in your file, you should enter "utf-8". If your file appears with text like this: or You may have selected the incorrect encoding. If this happens, you should immediately abort the edit and select the correct encoding. You should not save the file; this will likely corrupt the text permanently."

    The old fix of setting the language to english-UTF-8 no longer fixes the problem.

    I have checked the .lang file and it does contain the character set "english-utf8".

    It is confusing the hell out of my clients, does anyone know how to fix/suppress this message?
     
  2. linux.newbie

    linux.newbie Well-Known Member

    Joined:
    Sep 8, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Same here, is this a new feature, any way to suppress this message ?
     
  3. Nooberville

    Nooberville Registered

    Joined:
    Mar 14, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Wisconsin
    I also do have some questions regarding this.

    Not that I am bothered about the screen coming up. I like that it does, IF it were correct information and not so intimadating. Makes you worry that it don't/can't be sure what code it is reading.


    But my questions go a bit further, I do hope some DEV member would be of great help on this matter. I use a forum software, that requires that UTF-8 files be saved (when editing) to be saved in UTF-8 With-Out BOM.

    Because editing certain files say in like Microsoft Basic Notepad, saves them in UTF-8 WITH-BOM.

    I use cPanel Version 11.18.3-STABLE
    cPanel Build 21703
    cPanel File Manager v3

    It is the one I get/have with my hosting company. So I'm limited in what I get.

    However, there support is a tad bit under inviting to say the least.

    At the top of my Cpanel, I have three edit options.

    Edit , Code Editor , and HTML Editor.

    And when I choose one, I to get that screen that comes up.

    Am wondering if that thing is even accurate? On knowing the correct encoding?

    But, MY MOST important question is.

    Does these editors SAVE the UTF-8 encoding

    WITH OUT BOM?

    Unlike Micronot's basic Notepad... Which DOES include the BOM when saving UTF-8 type files.

    Can really screw up UTF-8 files if it does.

    I BADLY need to be told for sure..

    Thanks for any CORRECT info on this.

    :)
     
  4. Nooberville

    Nooberville Registered

    Joined:
    Mar 14, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Wisconsin
    No one in the DEV team know this?

    Thought I might add this, so I went and dug it up in one of the files. Though I have been reading about this issue elsewhere.

    Yah, I know, you might be thinking, why not ask them about this then?

    I did, and the answer/s come back to me each time, it has to do with the type of editor your are using to edit your files. The editor has to have the abilty of not adding BOM by default. When saving files in UTF-8.

    Hence why I am here. ;-)


    I went and opened one of the files in question, with basic notepad (just to look at it) to show you what it shows. This one is a .PHP file.

    In the comments section (in this file), it shows me:

    (All language files should use UTF-8 as their encoding and the files must not contain a BOM.)

    Now, in that file, there refering to language files.

    However, my concern applys to ANY files that the editor/s save in.

    KEY CONCERN: (files must not contain a BOM.)

    So, again, does the editors in Cpanel ADD this BOM when editing and saving?

    Thanks DEV team.

    :)
     
  5. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Note, the developers rarely browse these forums. If you are looking to speak to a developer, you may wish to reply to the open bugzilla entry regarding this issue:

    http://bugzilla.cpanel.net/show_bug.cgi?id=6327

    Otherwise, submit a support ticket regarding this inquiry so our support team can address it for you: http://tickets.cpanel.net/submit
     
Loading...

Share This Page