Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

File permission problem

Discussion in 'General Discussion' started by Hi World, Jun 27, 2011.

  1. Hi World

    Hi World Registered

    Joined:
    Jun 27, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    Hi,

    I am just install cPanel on my VPS and move my Joomla site to it.

    Site works fine, but when I try to install components I receive File permission error. All folders are set to 755, and files to 644. That combination works fine on my old hosting provider.

    Does anyone know what could be the problem and how to solve it?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,443
    Likes Received:
    416
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Owner of the files is your account, correct? Are you sure the new VPS is running SuPHP?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Hi World

    Hi World Registered

    Joined:
    Jun 27, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    VPS was runninng cgi. When I switched to suPHP problem is gone! :)

    Thanks Infopro! :cool:
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,443
    Likes Received:
    416
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Easy stuff then, good to hear. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Hi World

    Hi World Registered

    Joined:
    Jun 27, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    Site works fine with suPHP, but with fcgi site loads faster.

    Is it possible to solve the permission problem on servers that run fcgi? :confused:
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice