The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

File Permission Problems - for once and for all! - Urgent

Discussion in 'General Discussion' started by circlec, Feb 18, 2005.

  1. circlec

    circlec Active Member

    Joined:
    Jun 15, 2004
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Cape Town, South Africa
    Hi,

    I have posted on this forum about this before but never got any replies that solved the problem. I have therefore decided to open a new thread to hopefully sort this problem out for once and for all.

    If I suspend a perfectly working account, then unsuspend it and visit the site, I get a 403 Forbidden error. I try playing around with permissions but this does not solve the problem.

    I'm too scard to do a '/scripts/chownpublichtmls' as the last time I did this, it set ALL my public_html's to 403 Forbidden which caused an entire nightmare!

    I also have clients accounts who are showing 403 Forbidden and I am not sure what the correct permissions should be in order to get their accounts back up and running.

    PLEASE assist in replying with what exactly should be set.

    ie. chmod XXX /home/user/public_html/*
    or chown xx.xxx /home/user/public_html/
    or chmod x+x /home/user/*

    Please include however it should be done, and whatever should be done to the folders/files.

    I'm sure if we get some valued replies here then this post would do well for people doing searches on the same problem as I've heard/seen this type of thing on other servers too.

    Awaiting anybody's urgent assistance.
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    chmod 755 /home/user/public_html

    That will get you up and running quickly. However, the cause of your problem is with the user directory protect feature. Rebuild apache and select "Prevent Users from reading other webroots". This is a good thing, because it gives you a little added security. cpanel already apparently thinks that you've selected this, so it is chmoding the directories as 711. The ownership on the folder must be user:nobody, however, in order for this to work.

    chown user:nobody /home/user/public_html

    Checking the option above will do this for you automatically and remove any problems you might run into in the future.
     
  3. circlec

    circlec Active Member

    Joined:
    Jun 15, 2004
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Cape Town, South Africa
    Thank you so much for your reply, that simple little bit of information has enabled the clients folder again!

    Any explanation to why chownpublichtmls messes everything up and the same for suspend/unsuspend not working? Or is that what the rest of your reply is about?
     
  4. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    That's what the rest of the reply is about.

    If you'll rebuild apache with the said option I believe that your troubles will be over.
     
  5. circlec

    circlec Active Member

    Joined:
    Jun 15, 2004
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Cape Town, South Africa
    Once again, thank you so much. I will give it a try when I have the guts to recompile apache (things always go wrong) and will update the thread.
     
Loading...

Share This Page