The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

File upload - permission problems

Discussion in 'General Discussion' started by nsusa, Oct 24, 2004.

  1. nsusa

    nsusa Well-Known Member

    Joined:
    Jun 30, 2004
    Messages:
    93
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Colorado, USA
    I am working on an image uploading service. Everything works fine - the images get uploaded. No problem. However - the images cannot be linked to. It seems like that the uploaded images all receive CHMOD 600 settings. For seeing the images properly they will need 644. The upload folder has proper "777" settings.

    Is there a special setting in WHM or Cpanel that I need to set so that the scripts work? These scripts (here; Prozilla template) work just fine in other environments. A different script from a different maker has the same problem. That leads me to assume that there is a problem with the server/cpanel/WHM settings.

    I am on Redhat ES 3 with

    WHM 9.9.7 cPanel 9.9.8-S6
    RedHat Enterprise 3 i686 - WHM X v3.1.0

    as my setup. Everything is pretty much default.

    Any help would be appreciated.
     
  2. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    I'm having this problem as well - but only on my newest server. Running cPanel 10.1 build something (shrugs)

    any ideas anyone?
     
Loading...

Share This Page