Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Filezilla can't connect to all FTP accounts

Discussion in 'General Discussion' started by Shood, Jul 18, 2018.

Tags:
  1. Shood

    Shood Active Member

    Joined:
    Aug 12, 2015
    Messages:
    41
    Likes Received:
    8
    Trophy Points:
    83
    Location:
    Middle East
    cPanel Access Level:
    Root Administrator
    Hello,
    FileZilla was working fine before, I didn't used it within the last month
    Now my users cannot connect to their FTP, FileZilla returns an error message:
    Code:
    The data connection could not be established: ECONNREFUSED - Connection refused by server
    There are no changes happened on my server during the last months except cPanel updated to V72, is it possible that a some feature in the new version of cPanel caused this?
    Thank you.

    Here is full FileZilla error report:
    Code:
    Status:    Connecting to [Server_IP]:21...
    Status:    Connection established, waiting for welcome message...
    Status:    Initializing TLS...
    Status:    Verifying certificate...
    Status:    TLS connection established.
    Status:    Logged in
    Status:    Retrieving directory listing...
    Command:    PWD
    Response:    257 "/" is your current location
    Command:    TYPE I
    Response:    200 TYPE is now 8-bit binary
    Command:    PASV
    Response:    227 Entering Passive Mode (xxx_IP,75)
    Command:    MLSD
    Error:    The data connection could not be established: ECONNREFUSED - Connection refused by server
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @Shood,

    It looks like the passive ports for Pure-FTPd are not open on your system. Can you review the document linked below and verify passive mode is correctly configured on your system and the required ports are open?

    How to Enable FTP Passive Mode - cPanel Knowledge Base - cPanel Documentation

    Once we verify it's setup correctly, we can check to see if anything changes in version 72 that could have modified the previously configured settings.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Shood

    Shood Active Member

    Joined:
    Aug 12, 2015
    Messages:
    41
    Likes Received:
    8
    Trophy Points:
    83
    Location:
    Middle East
    cPanel Access Level:
    Root Administrator
    Hello @Michael
    I did what's mentioned in the article, I added local file with ForcePassiveIP settings because wasn't exist and restarted the PureFTP service. Also ports are allowed in CSF.
    Still unable to connect with the same error message.
    Thank you.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @Shood,

    Can you open a support ticket so we can take a closer look at the affected system? You can post the ticket number here and I'll update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Shood

    Shood Active Member

    Joined:
    Aug 12, 2015
    Messages:
    41
    Likes Received:
    8
    Trophy Points:
    83
    Location:
    Middle East
    cPanel Access Level:
    Root Administrator
    Thank you @Micheal.
    This is the ticket ID: 9957961
     
  6. Shood

    Shood Active Member

    Joined:
    Aug 12, 2015
    Messages:
    41
    Likes Received:
    8
    Trophy Points:
    83
    Location:
    Middle East
    cPanel Access Level:
    Root Administrator
    Hello @Micheal
    This document you've provided is enough to resolve this issue but I've done a shameful mistake :oops: I named the file literally "local file" but it should be "local"
    So I wasn't need to open a support ticket at all. I'm really sorry to waste your and support team time.

    However, fixing steps are as below:
    -----
    Add this file: /var/cpanel/conf/pureftpd/local
    Set the ForcePassiveIP option: ForcePassiveIP: 192.168.0.1
    Restart the PureFTP service: /usr/local/cpanel/scripts/setupftpserver pure-ftpd --force
    -----
    That's all.
    Thank you again and best regards.
     
    cPanelMichael likes this.
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @Shood,

    I'm glad to see you were able to solve the issue. Thank you for sharing the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Shood likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice