Filter Incoming Emails by Country - does not work

Operating System & Version
CENTOS 7.7
cPanel & WHM Version
v86.0.12

keat63

Well-Known Member
Nov 20, 2014
1,894
248
93
cPanel Access Level
Root Administrator
The TLD .CO doesn't neccesarily mean that the email originated from Columbia.
I'm going the guess that 'Block by country' will be based on the sending IP address and not the domain name.
 

keat63

Well-Known Member
Nov 20, 2014
1,894
248
93
cPanel Access Level
Root Administrator
You could try a global filter 'If From ends with'

RFC compliance says that you really should 'fail with message', but personally I would 'discard message' with no failure notice.

Do you have CSF firewall configured.
If so, can you indentify a pattern with the sending IP's, and block them there.?
 

nixuser

Well-Known Member
May 30, 2014
177
42
78
cPanel Access Level
Root Administrator
Twitter
You can block them using an exim system filter in the server.

For a particular account, it could be achieved through global filters or spamassassin block list, try adding something like *@*.co in the blocked list.
 

hub2000

Active Member
Dec 18, 2017
29
3
3
germany
cPanel Access Level
Root Administrator
You could try a global filter 'If From ends with'

RFC compliance says that you really should 'fail with message', but personally I would 'discard message' with no failure notice.

Do you have CSF firewall configured.
If so, can you indentify a pattern with the sending IP's, and block them there.?

...this does not work....as you can see
trying now the Spam filters / Black List Setting with *@*.co
 

Attachments

keat63

Well-Known Member
Nov 20, 2014
1,894
248
93
cPanel Access Level
Root Administrator
I guess it's possible that the return address as per your image is not the actual sending address, so maybe also try adding ' if reply ends with'