Filter Names Get Changed (on edit screen)

JJAC

Member
Feb 18, 2009
10
0
51
If I create a filter with the > character in the name, and then edit that filter, the > gets changed to >.

Similarly, it changes & to &
 

thewebhosting

Well-Known Member
May 9, 2008
1,199
1
68
Are you referring to email filters? Which cPanel Mail Interface are you using? please check character encoding settings.
 

JJAC

Member
Feb 18, 2009
10
0
51
Yes, I am referring to the e-mail filters.

I don't understand your question about which interface. When you log into webmail, you get a menu with three e-mail interfaces (horde, squirrelmail, roundcube), and a bunch of other options, including "Email Filtering". To creat/edit a filter, you select "Email Filtering" without selecting a mail interface.

What character encoding settings are you referring to?

Note that this did not occur in early version of cpanel.
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
If I create a filter with the > character in the name, and then edit that filter, the > gets changed to >.

Similarly, it changes & to &
Yes, I am referring to the e-mail filters.

I don't understand your question about which interface. When you log into webmail, you get a menu with three e-mail interfaces (horde, squirrelmail, roundcube), and a bunch of other options, including "Email Filtering". To creat/edit a filter, you select "Email Filtering" without selecting a mail interface.

What character encoding settings are you referring to?

Note that this did not occur in early version of cpanel.
Thank you for the report. I was able to reproduce the described filter name display behavior using 11.25.0-NIGHTLY_42506; for reference purposes, we are tracking this issue via the following internal case ID: #36453

To clarify, the filter name is saved correctly, but when certain characters are used in the name they are displayed differently on the edit screen making it appear the filter name may have changed, but if saving the rule again this may create a duplicate (using the different name).
 
Last edited: