Filtering BoxTrapper bounces? I thought I had a solution for this....

jols

Well-Known Member
Mar 13, 2004
1,110
3
168
I noticed that BoxTrapper bounces usually contain this in the header:

X-BoxTrapper-Match: errmsg: mailer/postmaster

But then I tried to establish a new filter in /etc/antivirus.exim like so:

or $message_headers: contains "X-BoxTrapper-Match: errmsg"

But no dice. Does not work for some reason.

Any suggestions to get this to work? Perhaps:

or $message_headers: contains "X\-BoxTrapper\-Match\: errmsg"

... or something to that effect?


Thanks much.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

You may want to consider utilizing a global filter for Exim. The global filter file is located at:

Code:
/etc/cpanel_exim_system_filter
You can copy this file to a new file and configure Exim to use the custom filter file via the following option under the "Filters" tab in "WHM Home » Service Configuration » Exim Configuration Manager":

"System Filter File"

Thank you.
 

jols

Well-Known Member
Mar 13, 2004
1,110
3
168
Thanks for the response. I appreciate it, but I'm not sure what this has to do with my original question?

There's nothing in cpanel_exim_system_filter that seems to address BoxTrapper messages bouncing back to the cPanel email account holder.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
I was offering an alternative to adding a filter rule to /etc/antivirus.exim to see if that helped allow it to work as you intended.

Thank you.