SOLVED find_outdated_services --auto” command reported error number 255 when it ended.

Oct 9, 2017
9
1
3
Delaware
cPanel Access Level
Root Administrator
During the nightly cPanel & WHM update process, we're receiving a message that states:

Code:
[/usr/local/cpanel/scripts/find_outdated_services] The “/usr/local/cpanel/scripts/find_outdated_services --auto” command (process 16662) reported error number 255 when it ended.
I ran find_outdated_services manually to see the output:

Code:
$ /usr/local/cpanel/scripts/find_outdated_services
Looking for outdated services …
STDERR: Failed to open connection to "system" message bus: Failed to connect to socket /run/dbus/system_bus_socket: Connection refused


Cpanel::Exception::ProcessFailed::Error/(XID 3ynyzf) “/usr/bin/dbus-send” reported error code “1” when it ended: Failed to open connection to "system" message bus: Failed to connect to socket /run/dbus/system_bus_socket: Connection refused

 at /usr/local/cpanel/Cpanel/ChildErrorStringifier.pm line 153.
        Cpanel::ChildErrorStringifier::die_if_error(Cpanel::SafeRun::Object=HASH(0x28c68b0)) called at /usr/local/cpanel/Cpanel/SafeRun/Object.pm line 534
        Cpanel::SafeRun::Object::new_or_die("Cpanel::SafeRun::Object", "program", "/usr/bin/dbus-send", "args", ARRAY(0x271ed60)) called at /usr/local/cpanel/Cpanel/Systemd.pm line 52
        Cpanel::Systemd::get_service_names_ar() called at /usr/local/cpanel/Cpanel/ProcessCheck/Outdated.pm line 117
        Cpanel::ProcessCheck::Outdated::outdated_services() called at /usr/local/cpanel/scripts/find_outdated_services line 83
        scripts::find_outdated_services::__ANON__() called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/Try/Tiny.pm line 93
        eval {...} called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/Try/Tiny.pm line 88
        Try::Tiny::try(CODE(0x2687bb8), Try::Tiny::Catch=REF(0x21c4a60)) called at /usr/local/cpanel/scripts/find_outdated_services line 92
        scripts::find_outdated_services::run(scripts::find_outdated_services=HASH(0x21980d8)) called at /usr/local/cpanel/scripts/find_outdated_services line 72
Has anyone had a similar problem?

I'm leaning towards trying a server reboot but wanted to check here in the forums first.

Thanks!