Fine tune MailScanner installation

testtubebaby

Member
Jul 28, 2007
16
0
51
I installed MailScanner using the following steps.....


# wget http://www.configserver.com/free/msinstall.tar.gz
tar -xzf msinstall.tar.gz
cd msinstall/
sh install.sh
Select option 1 to upgrade

# Check that MailScanner has restarted OK:


-bash-3.00# cat /var/log/maillog | grep MailScanner

Jul 28 00:12:47 server1 MailScanner[30500]: MailScanner E-Mail Virus Scanner version 4.60.8 starting...
Jul 28 00:12:47 server1 MailScanner[30500]: Using SpamAssassin results cache
Jul 28 00:12:47 server1 MailScanner[30500]: Connected to SpamAssassin cache database
Jul 28 00:12:49 server1 MailScanner[30500]: I have found scanners installed, and will use them all by default.
Jul 28 00:12:49 server1 MailScanner[30500]: You appear to have no virus scanners installed at all! This is not good. If you have installed any, then check your virus.scanners.conf file to make sure the locations of your scanners are correct
Jul 28 00:12:49 server1 MailScanner[30500]: Using locktype = posix
Jul 28 00:12:49 server1 MailScanner[30500]: Creating hardcoded struct_flock subroutine for linux (Linux-type)
Jul 28 00:12:52 server1 MailScanner[31798]: MailScanner E-Mail Virus Scanner version 4.60.8 starting...
Jul 28 00:12:52 server1 MailScanner[31798]: Using SpamAssassin results cache
Jul 28 00:12:52 server1 MailScanner[31798]: Connected to SpamAssassin cache database
Jul 28 00:12:53 server1 MailScanner[31798]: I have found scanners installed, and will use them all by default.
Jul 28 00:12:53 server1 MailScanner[31798]: You appear to have no virus scanners installed at all! This is not good. If you have installed any, then check your virus.scanners.conf file to make sure the locations of your scanners are correct
Jul 28 00:12:53 server1 MailScanner[31798]: Using locktype = posix
Jul 28 00:12:53 server1 MailScanner[31798]: Creating hardcoded struct_flock subroutine for linux (Linux-type)
Jul 28 00:12:57 server1 MailScanner[32037]: MailScanner E-Mail Virus Scanner version 4.60.8 starting...
Jul 28 00:12:57 server1 MailScanner[32037]: Using SpamAssassin results cache
Jul 28 00:12:57 server1 MailScanner[32037]: Connected to SpamAssassin cache database
Jul 28 00:12:58 server1 MailScanner[32037]: I have found scanners installed, and will use them all by default.
Jul 28 00:12:58 server1 MailScanner[32037]: You appear to have no virus scanners installed at all! This is not good. If you have installed any, then check your virus.scanners.conf file to make sure the locations of your scanners are correct
Jul 28 00:12:58 server1 MailScanner[32037]: Using locktype = posix
Jul 28 00:12:58 server1 MailScanner[32037]: Creating hardcoded struct_flock subroutine for linux (Linux-type)





How do I fine tune it... How do I know it is actually scanning emails?

In log it shows:-
--------------------
You appear to have no virus scanners installed at all! This is not good. If you have installed any, then check your virus.scanners.conf file to make sure the locations of your scanners are correct

How do I fix this?


Why is MailScanner sleeping all the time?

-bash-3.00# ps faxu | grep MailScanner
mailnull 30499 0.0 0.4 19512 16096 ? Ss 00:12 0:00 MailScanner: master waiting for children, sleeping
mailnull 30500 0.0 1.1 41384 38880 ? S 00:12 0:02 \_ MailScanner: waiting for messages
mailnull 31798 0.0 1.1 41384 38876 ? S 00:12 0:02 \_ MailScanner: waiting for messages
mailnull 32037 0.0 1.1 41384 38872 ? S 00:12 0:02 \_ MailScanner: waiting for messages
root 21778 0.0 0.0 1576 480 pts/0 S+ 02:09 0:00 \_ grep MailScanner



Please advise .. thank you.
 

lloyd_tennison

Well-Known Member
Mar 12, 2004
697
1
168
Did you actually upgrade? If you did not have it you would need a new install.
 

testtubebaby

Member
Jul 28, 2007
16
0
51
Hello,


Ok I have installed clamav /mailscanner as per configserver.... what will clamav do if its finds an email with virus/phishing content? How do I change the behaviour of the action clamav will take, if it finds an email with virus?



Thanks