First 8 characters conflict with one or more other usernames

HostXNow_Chris

Active Member
PartnerNOC
Jan 22, 2016
40
30
18
United Kingdom
cPanel Access Level
DataCenter Provider
Twitter
Hi,

Any idea how to turn off the following when trying to migrate cPanel accounts from one server to another?

The following <insert number> remote users are set to migrate with new names whose first 8 characters conflict with one or more other proposed new usernames. To resolve this, you can either rename the incoming accounts or deselect them.

When migrating many servers at the same time it can really slow the work rate down. I read somewhere if using MariaDB it would not do this but it is with latest version 10.3
 

sparek-3

Well-Known Member
Aug 10, 2002
1,929
178
343
cPanel Access Level
Root Administrator
Welcome to cPanel... where what we do, doesn't always make a lot of sense.

Kudos to whoever it was that thought allowing longer than 8 character usernames would be a great idea - so long as the first 8 characters are unique! Great idea!

Seriously though, yea this was enabled in cPanel some time ago when most were still using MySQL which had a certain character limit. MariaDB greatly lifted this limit and it may now be lifted in MySQL. But the cPanel system still requires the first 8 characters of every username to be unique.

I said it then and I'm still saying it... if the first 8 characters of a username have to be unique... then what's the point of having longer than 8 character usernames? That's just stupid if you ask me. Either lift the restriction on the first 8 characters having to be unique (which depends on MySQL/MariaDB username limits, of which I have not followed) or the inclusion of longer than 8 character usernames never should have been enacted.
 
  • Like
Reactions: HostXNow_Chris

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,234
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @HostXNow_Chris,

With MariaDB, you can disable the following option under the SQL tab in WHM >> Tweak Settings to bypass the eight-character unique username requirement:

Require a username prefix on names of new databases and database users

Here's this option's description:

When this option is enabled, the system will require that the name of each new database or database user from a cPanel session begin with the system username and an underscore (_). This makes it easier to tell which user owns a given database, but it also restricts the number of characters that users can use for names of databases and database users. Note that if the username changes at a later point, the name of the database or database user does NOT change. Also, while older cPanel API calls automatically add this prefix, newer API calls expect the caller to add it.
Let me know if this helps.

Thank you.
 
  • Like
Reactions: HostXNow_Chris

HostXNow_Chris

Active Member
PartnerNOC
Jan 22, 2016
40
30
18
United Kingdom
cPanel Access Level
DataCenter Provider
Twitter
Hello @HostXNow_Chris,

With MariaDB, you can disable the following option under the SQL tab in WHM >> Tweak Settings to bypass the eight-character unique username requirement:

Require a username prefix on names of new databases and database users

Here's this option's description:



Let me know if this helps.

Thank you.
I did not see that setting before. I wish I knew that before spending 2 hours doing it all manually. :)

I shall try it. Thanks.
 

HostXNow_Chris

Active Member
PartnerNOC
Jan 22, 2016
40
30
18
United Kingdom
cPanel Access Level
DataCenter Provider
Twitter
@cPanelMichael actually I already found that setting and turned it off, but it still shows the same error as mentioned before?

Why does it say it is going to rename the database from a name to the same name as below

Error: The following 9 remote users are set to migrate with new names whose first 8 characters conflict with one or more other proposed new usernames. To resolve this, you can either rename the incoming accounts or deselect them.

“user1” is set to be renamed “user1”.
“user2” is set to be renamed “user2”.
“user3” is set to be renamed “user3”.
“user4” is set to be renamed “user4”.
“user5” is set to be renamed “user5”.
“user5” is set to be renamed “user6”.
“user6” is set to be renamed “user7”.
“user7” is set to be renamed “user8”.
“user8” is set to be renamed “user9”.

Bug?