The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fix for Server URL 301 Redirecting to Error Page

Discussion in 'General Discussion' started by jwogrady, Jun 27, 2016.

Tags:
  1. jwogrady

    jwogrady Member

    Joined:
    Jul 9, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    When I visit my WHM server, which is on lets say is myserver.domain.com, I am 301 redirected to an error page.

    http://myserver.domain.com/cgi-sys/defaultwebpage.cgi

    What is the expected behavior?

    What I want to happen is for the server url to redirect port 80 folks to the secure WHM login screen like this....

    myserver.domain.com -> https://myserver.domain.com:2087

    More details on my scenario....

    - when I go directly to myserver.domain.com/whm I am correctly redirected to the secured whm login screen. This is also true for myserver.domain.com/cpanel

    - myserver.domain.com is the whm hostname, but myserver.domain.com does not have a hosting account on the WHM server.

    - I do have a valid wildcard ssl certificate for myserver.domain.com.

    - My Tweaks "Always redirect to SSL" is marked yes, but that feature doesn't give me an option to specify a valid ssl destination. Why?

    - I ran scripts/rebuildhttpdconf and get "Missing owner for domain bolt.example.com, force lookup to root".

    What I want...

    #1

    By default I want clients and admins visiting the server's domain on port 80 to get redirected to a secure WHM login screen....

    #2

    Since I have a wildcard ssl..... I would like an option to make my hosting customer's temp urls to be.....

    https://{cpaneluser}.domain.com instead https://myserver.domain.com/~cpaneluser

    ... with proper http: redirect of course....

    For now, I would settle for understanding current best practice as they relate to the expected default behavior.

    I can't tell right now if things are working by design... or if I set something up wrong....
     
    #1 jwogrady, Jun 27, 2016
    Last edited by a moderator: Jun 28, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page