Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Fix Found: cPanel fails to start

Discussion in 'General Discussion' started by SupportedServer, Apr 27, 2008.

  1. SupportedServer

    SupportedServer Registered

    Apr 18, 2008
    Likes Received:
    Trophy Points:
    Recently we have had reports from clients on two of our cPanel servers stating that cPanel and WHM would not load. After investigating the issue, we noticed the following:

    service cPanel restart
    via SSH (as root) showed that cPanel itself could not be started (all other portions of the service started without an issue).

    The following email was sent to one of the email addresses that we use to monitor our servers:

    Subject: cpsrvd on (hostname) failed
    Body: cpsrvd failed @ (time and date). A restart was attempted automagically.
    After attempting multiple other fixes (including restarting the servers), we found the solution:

    solved the issue. A complete update was performed, and cPanel/WHM worked as it should as soon as the update was complete.


    My guess is that one of the cPanel updates failed to complete, or had an error during the update process. Initiating another update via SSH corrected this issue.


    This issue did not occur on all of our cPanel servers. The two servers that had the error were running cPanel "current".


    If any of you experience something similar, but are unable to correct the issue using the instructions in this post, feel free to send me a PM.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice