The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fix Found: cPanel fails to start

Discussion in 'General Discussion' started by SupportedServer, Apr 27, 2008.

  1. SupportedServer

    SupportedServer Registered

    Joined:
    Apr 18, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Recently we have had reports from clients on two of our cPanel servers stating that cPanel and WHM would not load. After investigating the issue, we noticed the following:

    Running
    Code:
    service cPanel restart
    via SSH (as root) showed that cPanel itself could not be started (all other portions of the service started without an issue).

    The following email was sent to one of the email addresses that we use to monitor our servers:

    Code:
    Subject: cpsrvd on (hostname) failed
    
    Body: cpsrvd failed @ (time and date). A restart was attempted automagically.
    After attempting multiple other fixes (including restarting the servers), we found the solution:

    Running
    Code:
    /scripts/upcp
    solved the issue. A complete update was performed, and cPanel/WHM worked as it should as soon as the update was complete.

    Conclusion:

    My guess is that one of the cPanel updates failed to complete, or had an error during the update process. Initiating another update via SSH corrected this issue.

    Notes:

    This issue did not occur on all of our cPanel servers. The two servers that had the error were running cPanel "current".

    -----

    If any of you experience something similar, but are unable to correct the issue using the instructions in this post, feel free to send me a PM.
     
Loading...

Share This Page