The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[FIXED] [CASE 57688] TAP::Parser::Aggregator notification e-mails

Discussion in 'E-mail Discussions' started by ibanez0r, Feb 24, 2012.

  1. ibanez0r

    ibanez0r Member

    Joined:
    Apr 5, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Melbourne, AU
    I've started seeing this in nightly my email reports:

    upcp is not running.
    Can't locate object method "meta" via package "TAP::Parser::Aggregator" (perhaps you forgot to load "TAP::Parser::Aggregator"?) at /usr/local/cpanel/Cpanel/Class/Object.pm line 94.

    and then!!

    The chkservd sub-process with pid 8159 was running for 301 seconds. The sub-process was terminated as it exceeded the time between checks of 300 seconds. Please check /var/log/chkservd.log and /usr/local/cpanel/logs/tailwatchd_log to discover the cause.

    So i load these logs, the PID isnt in them :( ?
     
  2. ibanez0r

    ibanez0r Member

    Joined:
    Apr 5, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Melbourne, AU
    or should i say that IS the nightly log :(
     
  3. aontech

    aontech Member

    Joined:
    Sep 29, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cherryvale, KS
    I've been getting this emailed error message since 2-22-2012:

    upcp is not running.
    Can't locate object method "meta" via package "TAP::Parser::Aggregator" (perhaps you forgot to load "TAP::Parser::Aggregator"?) at /usr/local/cpanel/Cpanel/Class/Object.pm line 94.

    My cPanel distributor's support has verified that upcp us running correctly when it's called. When it finishes, it terminates itself.

    I verified that the TAP::Parser::Aggregator module is not installed ... and it is not available to install.

    I have seen some reference that an update in the works will correct this issue, but do not know if it has been issued into auto updates or what the current status is. I just want to be sure this isn't an indicator of sdme other problem I need to address.

    If there's any additional information regarding this, an update would be appreciated.
     
  4. JayFromEpic

    JayFromEpic Well-Known Member

    Joined:
    Apr 2, 2011
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Scottsdale, AZ
    cPanel Access Level:
    Root Administrator
    That is a very odd issue. I personally have never seen this issue in the 4 years I have been dealing with cPanel on a Root Administration aspect. I suggest creating a cPanel Support ticket and having one of the actual cPanel techs look into this as it is obviously not normal.

    I could see this as an issue where this thread will come up in someone's google search on the issue.
     
  5. ibanez0r

    ibanez0r Member

    Joined:
    Apr 5, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Melbourne, AU
    Yeh, same, ive been working with cpanel, and even helped pioneer the freebsd releases and in all this time ive never seen this error, ive done the same, checked everything... somethings not right..

    My vendor is pretty much useless, unorganised and not able to resolve this bug that started happening on its own, i guess ill request support from cpanel themselfs and explain my position and hope and pray they help.
     
  6. JayFromEpic

    JayFromEpic Well-Known Member

    Joined:
    Apr 2, 2011
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Scottsdale, AZ
    cPanel Access Level:
    Root Administrator
    cPanel's free support is top notch. I trust my servers in their hands any day. All they deal with is cPanel and don't worry about a lot of other issues so if its a cPanel issue and they cant fix in the support department, I can guarantee they will have a developer look into it.
     
  7. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    There is no charge to submit a ticket. We are happy to log in and look at a problem like this. If there is a problem with the cPanel software, we will either fix it or advise you what you may need to do to fix it. If there is a problem caused by third-party software or other factors not directly related to cPanel (base operating system, hardware, network), we will give you avenues you can follow to solve the problem or find someone who can.
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Currently, we have internal case 57688 on this issue where we are collecting data on what is causing this to occur. In order to have sufficient systems for replicating the issue, please submit a ticket using WHM > Support Center > Contact cPanel or using the link in my signature. It would be great if anyone who submits a ticket could post it here for further follow up as well.
     
  9. nerod

    nerod Member

    Joined:
    Feb 4, 2011
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I've been having this issue for a few days as well. My host has checked and confirmed everything is installed, however there were missing dependencies.

    They recompiled perl and tried to install the missing dependencies, yet the issue persists.
     
  10. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    This problem has been identified and it will be fixed in an upcoming version. As a workaround, you can do this:

    Code:
    # cd /usr/local/cpanel/Cpanel/Class/
    # mv Object.pm /root
    What is happening is the Object.pm file in /usr/local/cpanel/Cpanel/Class is being loaded, and it is no longer used. Moving it will cause Object.pm to be loaded from the system Perl directories, which is what is intended.
     
  11. JayFromEpic

    JayFromEpic Well-Known Member

    Joined:
    Apr 2, 2011
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Scottsdale, AZ
    cPanel Access Level:
    Root Administrator
    Thank you Jared for the update. See everyone, told you the cPanel techs are top notch. Always find a way if its physically possible.

    On another note, I love the look of 11.32 login page and so forth, my customers thought it was much needed.
     
  12. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The fix is now propagating with versions 11.32.2.0 and later :).
     
Loading...

Share This Page