Fixed case CPANEL-37048: Remove support for legacy mod security 2 configuration.

Operating System & Version
CentOS 7.9
cPanel & WHM Version
98.0.5

701Hosting

Member
Dec 15, 2017
23
1
3
USA
cPanel Access Level
Root Administrator
Updated WHM from 96 to 98 yesterday and CSF doesn't seem to be blocking using modsecurity rules. Then I noticed that update. Does Mod_Security still work with WHM 98? How can be get it working?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,028
313
cPanel Access Level
Root Administrator
Hey there! Please remember that CSF and CMC is not part of cPanel, so we can't say if any changes or updates need to be applied to that software.

I've been running version 98 on my personal machine for a while now and I have not seen any issues with ModSecurity itself. Do you see ModSecurity working outside of those tools? Are there any entries in the Apache log at /etc/apache2/logs/error_log that show an issue with ModSecurity?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,028
313
cPanel Access Level
Root Administrator
I'm glad to hear that's working well. You wouldn't have to reinstall anything as part of the 98 update if mod_security was already installed and working.

You could run the following command to check for that package - if you get a result, it's installed and running.

Code:
rpm -qa | grep ea-apache24-mod_security
 

701Hosting

Member
Dec 15, 2017
23
1
3
USA
cPanel Access Level
Root Administrator
It's installed and working. Thank you. We are trying to troubleshoot a slowdown in our system since 98 update. We are noticing PHP-FPM using alot of CPU since the update. Has there been any report of that?