The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

fixeverything: touch aquota.user

Discussion in 'General Discussion' started by fedlerner, Apr 3, 2008.

  1. fedlerner

    fedlerner Active Member

    Joined:
    Oct 31, 2007
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Argentina
    I'm getting the following error after running fixeverything (I assume I'll get it too after running fixquotas).

    Code:
    touch: cannot touch `/usr/aquota.user': Permission denied
    touch: cannot touch `/usr/aquota.user': Permission denied
    touch: cannot touch `/var/aquota.user': Permission denied
    touch: cannot touch `/var/aquota.user': Permission denied
    touch: cannot touch `/aquota.user': Permission denied
    touch: cannot touch `/aquota.user': Permission denied
    touch: cannot touch `/home/aquota.user': Permission denied
    touch: cannot touch `/home/aquota.user': Permission denied

    What can I do to fix this?
     
  2. fedlerner

    fedlerner Active Member

    Joined:
    Oct 31, 2007
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Argentina
    Adding: I'm doing this as the "root".
     
  3. LiNUxG0d

    LiNUxG0d Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gatineau, Quebec, Canada
    Hi there,

    It's possible that the files are attributed "+i".

    You may need to "chattr -i /path/to/file" though, honestly, I don't know why it would be the case. Though, I've seen weirder things happen!

    Also, check the `dmesg` command; is your file-system in read-only for the /usr partition?

    Give it a go if you want, with one file to start, to see if it disappears from the list of "Permission Denied" candidates! :)

    Regards,
     
  4. fedlerner

    fedlerner Active Member

    Joined:
    Oct 31, 2007
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Argentina
    hmmmmmmm.. Can you give me a more understandable explanation for a newbie in this stuff ? :D

    Thanks for helping.
     
  5. LiNUxG0d

    LiNUxG0d Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gatineau, Quebec, Canada
    Hi there,

    Let's try this. Can you log into your server - as root via SSH - and issue the following command:

    Code:
    [root@server ~]# lsattr /usr/aquota.user
    It will return something like:

    Code:
    [root@server ~]# lsattr /usr/aquota.user
    ------------- /usr/aquota.user
    
    If instead of "-------------" in the output, you see, say, "----i--------" then your file is set with the "immutable bit" on! Basically, immutable is geek for "can't touch this, edit it, save it or overwrite it". I have rarely seen this set on the quota files, but it may happen; I've seen stranger things. ;)

    Using the chattr command (which stands for change attribute) I showed you before will turn the immutable bit off. Basically +i is on, -i is off.

    I hope this helps more? Sorry for being uber-nerd up top there. ;) My bad, man. :)

    Regards,
     
  6. fedlerner

    fedlerner Active Member

    Joined:
    Oct 31, 2007
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Argentina
    Code:
    [root@server ~]# lsattr /usr/aquota.user
    ------------- /usr/aquota.user
    [root@server ~]# lsattr /aquota.user
    ------------- /aquota.user
    [root@server~]# lsattr /home/aquota.user
    ------------- /home/aquota.user
    It seems it isn't that :(
     
  7. LiNUxG0d

    LiNUxG0d Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gatineau, Quebec, Canada
    Hmmmm,

    Interesting. Can you issue and ls on them and show me the result?

    Code:
    [root@server ~]# ls -la /usr/aquota.user
    -rwxr--r-- 1 root root 27648 Apr  4 01:04 /usr/aquota.user*
    
    Are the perms ok? I mean, if they are root:root but, say, permissions 444 (r--r--r--) then this might (I say this lightly) be the cause.

    If no special attributes are on, and permissions are find and you're root, I'll be totally baffled!

    Short of being on your server checking your files and logs, I'm short on options.

    Let me know,
     
  8. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This is standard for the Linux quota files. In order to 'touch' one of the quota files, one must turn off quotas. It is the quota kernel subsystem that is blocking the access.
     

Share This Page