The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

fixquota script error

Discussion in 'General Discussion' started by david510, Nov 9, 2005.

  1. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    I am having a BIG problem with my server. When I run the fixquota script I am getting the following message. Cpanel and whm shows the quota used by the accounts as 0 Disk usage. I cannot figure out the issue. The seerver is a VPS server. Please see the fstab entry

    root@dsds [/]# cat /etc/fstab
    none /dev/pts devpts rw 0 0

    I checked with other VPS and found that all are having the same fstab entries. The usrquota entry is not needed here. I cannot figure out what is causing this. Is this any kernel level error?

    If somebody have come accross this error please help me!!

    Regards,
    David

    # /scripts/fixquotas
    Installing Default Quota Databases......Done
    Quotas are now on
    Updating Quota Files......
    quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.


    quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.

    ....Done
    Note: call resetquota with --useplanquotas to reset all quotas to plan defaults
    No filesystems with quota detected.
    Resetting quota for accxxx to 100 Meg....Done
    No filesystems with quota detected.
    Resetting quota for advxxx to 100 Meg....Done
    No filesystems with quota detected.
    Resetting quota for aerxxx to 10 Meg....Done
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    You need to recompile the kernel and add/activate quota option.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Indeed. It's a problem with the Virtuozzo VPS and you either need to speak to them or your VPS provider.
     
  4. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    I found out the solution.

    The qiotas in the VPS is controlled by the main virtuzzo server. Here there will be a conf file for each VPS's. For example say for a server numbered 103 the file will be /etc/sysconfig/vz-scripts/103.conf. In this file the value of the variable QUOTAUGIDLIMIT should not set set to 0 or some minimum value. It could be set to a value in the range 300. Once this is set restart server 103. Now enter into the server 103 and run the fixquotas.

    Regards,
    David
     
Loading...

Share This Page