The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixquotas problem

Discussion in 'General Discussion' started by black&white, Aug 4, 2006.

  1. black&white

    black&white Well-Known Member

    Joined:
    Aug 10, 2004
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    0
    Hi,
    I type /scripts/fixquotas and i have


    Can't locate version.pm in @INC (@INC contains: /scripts
    /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7
    /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7
    /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
    /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
    /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
    /usr/lib/perl5/site_perl . /usr/local/cpanel) at
    /scripts/cPScript/cPQuota.pm line 11.
    BEGIN failed--compilation aborted at /scripts/cPScript/cPQuota.pm line 11.
    Compilation failed in require at /scripts/resetquotas line 15.
    BEGIN failed--compilation aborted at /scripts/resetquotas line 15.

    I have tried everything but i can't fix my issue.

    Please help!

    Thank you
     
  2. amal

    amal Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    reinstall version and run upcp. :)

    /scripts/perlinstaller --force version
    /scripts/upcp --force
     
  3. liwiplus

    liwiplus Member

    Joined:
    Jul 22, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Try installing version manually by,

    cd /home/.cpan/build/version-0.662

    perl Makefile.PL
    make
    make install

    This should fix the issue.
     
  4. NoAgendas

    NoAgendas Guest

    I'm having this problem too

    Copying form one server (cpanel) to another (cpanel)

    multicopy / transfer option in whm is showing a blank list, but there are 60 accounts on the source server.

    I upgraded cpanel to current, same thing.

    Disabled apf / iptables and reset sshd to default, same problem


    Restarted cpanel, same issue. Rebooted, same issue

    I reinstalled perl587, upcp --force again.

    I can ping from the new server to the source server as well.

    cpanel error logs:

    Can't locate version.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /usr/local/cpanel/Cpanel/Lang/Cache/Utils/Cachelangfiles.pm line 11.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Lang/Cache/Utils/Cachelangfiles.pm line 11.
    Compilation failed in require at /usr/local/cpanel/bin/cachelangfiles line 11.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cachelangfiles line 11.
    Can't locate IO/Tty.pm in @INC (@INC contains: /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /scripts/sshcontrol line 13.
    ...propagated at /scripts/sshcontrol line 20.
    Can't locate IO/Tty.pm in @INC (@INC contains: /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /scripts/sshcontrol line 13.
    ...propagated at /scripts/sshcontrol line 20.
    Can't locate version.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /usr/local/cpanel/Cpanel/Lang/Cache/Utils/Cachelangfiles.pm line 11.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Lang/Cache/Utils/Cachelangfiles.pm line 11.
    Compilation failed in require at /usr/local/cpanel/bin/cachelangfiles line 11.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cachelangfiles line 11.
    [Mon Aug 14 20:05:46 2006] diskusage.cgi: [Mon Aug 14 20:05:46 2006] diskusage.cgi: Can't locate Tie/IxHash.pm in @INC (@INC contains: /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl . /usr/local/cpanel /usr/local/cpanel/whostmgr/docroot/cgi) at /usr/local/cpanel/whostmgr/docroot/cgi/parseform.pl line 6.



    root@server [~]# cd /home/.cpan/build/version-0.662
    -bash: cd: /home/.cpan/build/version-0.662: No such file or directory
     
  5. pross

    pross Well-Known Member

    Joined:
    Mar 14, 2005
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Seems to be impossible to install version!!


    root@server [/scripts]# /scripts/perlinstaller --force version
    Method: Perl Expect
    Testing connection speed...(this could take a while)...Done
    Ping:7.220 Testing mirror speed and update status (cpan.belfry.net) using wget...(275920 bytes/s)...Done
    Ping:2.038 Testing mirror speed and update status (cpan.glines.org) using wget...(1080000 bytes/s)...Done
    Ping:7.046 Testing mirror speed and update status (cpan.erlbaum.net) using wget...(1890000 bytes/s)...Done
    Three usable mirrors located
    Mirror Check passed for cpan.erlbaum.net (/index.html)
    commit: wrote '/usr/lib/perl5/5.8.7/CPAN/Config.pm'
    CPAN: File::HomeDir loaded ok
    CPAN: Storable loaded ok
    Going to read /home/.cpan/Metadata
    Database was generated on Tue, 15 Aug 2006 02:32:04 GMT
    Running install for module version
    Running make for J/JP/JPEACOCK/version-0.67.tar.gz
    CPAN: Digest::SHA loaded ok
    CPAN: Compress::Zlib loaded ok
    Checksum for /home/.cpan/sources/authors/id/J/JP/JPEACOCK/version-0.67.tar.gz ok
    Scanning cache /home/.cpan/build for sizes
    version-0.67/
    version-0.67/t/
    version-0.67/t/02derived.t
    version-0.67/t/coretests.pm
    version-0.67/t/03require.t
    version-0.67/t/01base.t
    version-0.67/lib/
    version-0.67/lib/version.pod
    version-0.67/lib/version/
    version-0.67/lib/version/typemap
    version-0.67/lib/version.pm
    version-0.67/vperl/
    version-0.67/vperl/vpp.pm
    version-0.67/vutil/
    version-0.67/vutil/lib/
    version-0.67/vutil/lib/version/
    version-0.67/vutil/lib/version/vxs.pm
    version-0.67/vutil/ppport.h
    version-0.67/vutil/vxs.xs
    version-0.67/vutil/vutil.c
    version-0.67/vutil/vutil.h
    version-0.67/README
    version-0.67/Changes
    version-0.67/Build.PL
    version-0.67/MANIFEST.SKIP
    version-0.67/Makefile.PL
    version-0.67/META.yml
    version-0.67/MANIFEST
    Removing previously used /home/.cpan/build/version-0.67
    CPAN: Module::Build loaded ok

    CPAN.pm: Going to build J/JP/JPEACOCK/version-0.67.tar.gz

    Creating custom builder _build/lib/version/Builder.pm in _build/lib/version
    Checking whether your kit is complete...
    Looks good

    Checking prerequisites...
    Looks good

    Checking whether your kit is complete...
    Looks good

    Checking prerequisites...
    Looks good

    Creating new 'Build' script for 'version' version '0.67'
    CPAN: YAML loaded ok
    Can't locate object method "up_to_date" via package "version::Builder" (perhaps you forgot to load "version::Builder"?) at ./Build line 45.
    ./Build -- NOT OK
    Running Build install
    make had returned bad status, install seems impossible
    perlmod--Install done
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    liwiplus already gave the solution to fixing the version module if perlinstaller doesn't do it.
     
Loading...

Share This Page