The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

For all the exim experts - problems with bounces

Discussion in 'General Discussion' started by ctmattice, Sep 26, 2006.

  1. ctmattice

    ctmattice Member

    Joined:
    Nov 4, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi all,

    I'm having a problem locating the right way to setup a filter for a client. Not sure exactly why I should have to set it up either, maybe someone can shine some light on the issue.

    I'm running cPanel 10.8.2-c118 with default antivirus.exim system filter on a RH3 box.

    Have all my clients use :fail:

    phpsuexec is on as well as suexec

    In the majority of cases the users will get their bounce messages if they send mail from their email accounts and everything appears to work as it should -- Except

    One client uses a script called Post Office, they send out a ezine announcement using this perl script. Mailings go out fine and they were receiving bounces up to the point where they were getting so much spam I had them set the default email to :fail: and use email accounts and forwarders.

    Since then they have not been getting any bounces and were recently blacklisted by SpamCop. That's another story relating to bounce backs though as the week they were black listed SpamCop said they had trapped email from them and my client (verifed by logs) hadn't sent anything from the server.

    I've searched the forums for hours and read the exim docs but this brain can't find a solution. anyone with some idea's as to why this is happening and how to correct it.

    TIA
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Please, read this thread: http://forums.cpanel.net/showthread.php?t=57950
     
  3. ctmattice

    ctmattice Member

    Joined:
    Nov 4, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1

    I've read that one several times and setting up the bounceback filter would help. Your note on autoresponders being the culprit is correct. I'll search for them. What I can't seem to grasp is how to override the exim :fail: so the client will start getting legit autoresponder bounces

    in the filter
    Code:
    
    if $sender_address is “”
    then
    if ${lookup{${extract{2}{@}{$recipients}}}lsearch{/etc/localdomains}{yes}{no}} is “no”
    then
    headers add “Old-Subject: $h_subject:”
    headers remove “Subject”
    headers add “Subject: [Delayed Bounce]$h_old-subject:”
    headers remove “Old-Subject”
    deliver “abuse@yourdomain.com”
    fail text “Delayed bounce message ignored”
    seen finish
    endif
    endif
    I see where it is searching for localdomains and if it doesn't find it then fails it and in this case sends a email as well, it could also be logged to a file as well. In looking at a header the return path is the domain email of the account however it is currently set to :fail:

    :eek: Since this is unacceptable and I want the main delivered to the correct address (the From: header ) I could add a else clause. logically, the header of the autoresponder has the correct from address so I could add
    Code:
    else
                 deliver "$header_from"
                 seen finish
               endif
    
    Thanks Andy for pointing me in the right direction, now to make it work
     
Loading...

Share This Page