The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Force password auth for SMTP

Discussion in 'E-mail Discussions' started by smithy, Dec 20, 2005.

  1. smithy

    smithy Registered

    Dec 19, 2005
    Likes Received:
    Trophy Points:

    We have a server with several hosting accounts on it, and we are having trouble with spam.

    We do not offer SMTP service to our hosting customers, but we want to use the server as out office SMTP server. Also there are various scripts and contact forms on the server that should be allowed to send out email.

    So, ultimately what we want is:

    1. The SMTP server to ask for a username and password form the mail client before you can send any email.
    2. I don't want to use the user login username/passwords, I just want one username and password for connecting to the SMTP server.
    3. Any scripts running on the server are permitted to send email without having to supply a password.

    According to what I have read on these forums, CPanel servers come with SMTP preconfigured such that it has 2 form of authentication:

    1. SMTP AUTH
    2. POP before SMTP

    I do not wish to use POP before SMTP. I want to use a username and password for SMTP access. I have tried disabling ‘antirelayd’ and removing all the IP's from the relayhosts file, but SMTP is still permitted without password authentication.

    when I configure Outlook to use password authentication it works, and when I turn off password authentication it still works !?!?!

    Please, Can someone tell me how I can configure Exim to require password *at all times*, and to allow anything coming from localhost?

  2. RickG

    RickG Well-Known Member

    Feb 28, 2005
    Likes Received:
    Trophy Points:
    North Carolina
    A couple of suggestions:

    1) Create a blank file called antirelayddisable in the /etc/ directory
    2) Clear out any values in /etc/relayhosts and /etc/relayhostsusers
    3) Restart Exim using: /etc/init.d/exim restart

    That should take care of it. As long as relayhosts and relayhostsuers stay blank (which normally are updated each time you check mail under the POP before SMTP scenario), you are all set.

    Give this a try and let us know if this helps -
  3. chirpy

    chirpy Well-Known Member

    Jun 15, 2002
    Likes Received:
    Trophy Points:
    Go on, have a guess
    To disable pop before SMTP you simply have to untick both the boxes next to antirelayd in WHM > Service Manager.

    As the SMTP AUTH, you would have to write your own ACL code for exim.conf to use an alternative SMTP AUTH mechanism for authentication for relaying, which should be fairly straightforward.

Share This Page