The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forcing HTTPS on insecure login

Discussion in 'General Discussion' started by cwihost, Oct 17, 2007.

  1. cwihost

    cwihost Member

    Joined:
    Sep 9, 2001
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    6
    Is there a away to force users logging in with http://servername:2082 or http://IP:2082 to the secure port. Also the same request for WHM logins via the port.

    I am aware of the option in tweak settings to force /whm /webmail and /cpanel to secure connections however this is only for the direct URL match. I already have that enabled and it works with respect to what it does. However even with that option on someone can access :2082 or :2086 and still gain access.

    I tried a IPTables rule to forward port 2082 to 2083 and 2086 to 2087 etc. However an error occurs when doing this as the http:// needs to change to https:// to work.

    Does anyone have any ideas on this?
     
  2. jenlepp

    jenlepp Well-Known Member

    Joined:
    Jul 4, 2005
    Messages:
    116
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Liberty Hill, TX
    cPanel Access Level:
    DataCenter Provider
    I force a forward to the server name, and then require secure logins - if you force https on their domain name, and they don't have a cert, there's going to to be errors.
     
  3. cwihost

    cwihost Member

    Joined:
    Sep 9, 2001
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    6
    Draknet:

    How are you setting this up on your server? I just want to make sure that they cannot login with the insecure ports still.
     
  4. jenlepp

    jenlepp Well-Known Member

    Joined:
    Jul 4, 2005
    Messages:
    116
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Liberty Hill, TX
    cPanel Access Level:
    DataCenter Provider
    I purchased certs for the server names and installed them (without that, the self-signed style will give errors and I think, on IE7, will choke and not even let you go to the page).

    Under "Server Config/Tweak Settings" in WHM I have:

    Always redirect users to the ssl/tls ports when visiting /cpanel, /webmail, etc. checked
    When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to:
    Hostname checked

    And I think I had to restart cPanel to get it to take, but that's it.
     
Loading...

Share This Page