Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Format/Mount a new drive process failed or incomplete. Unable to mount.

Discussion in 'General Discussion' started by ronald.prism, Dec 26, 2011.

  1. ronald.prism

    ronald.prism Member

    Joined:
    Dec 26, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Website Owner
    I'm on WHM 11.30.5 (build 3)


    Did the "Format/Mount a new drive" function in cpanel but although we received the PROCESS COMPLETED message at the end, the newly formatted drive could not be mounted.

    Mount point /home2

    fdisk -l output:

    # /sbin/fdisk -l


    Disk /dev/sda: 251.0 GB, 251059544064 bytes
    255 heads, 63 sectors/track, 30522 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes


    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 32 257008+ 83 Linux
    /dev/sda2 33 30522 244910925 8e Linux LVM


    Disk /dev/sdb: 251.0 GB, 251059544064 bytes
    255 heads, 63 sectors/track, 30522 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes


    Device Boot Start End Blocks Id System
    /dev/sdb1 1 30522 245167933+ 83 Linux


    /etc/fstab entry:
    /dev/sdb1 /home2 ext3 defaults,usrquota 1 2


    Attempts to mount manually result in:
    # mount -t ext3 /dev/sdb1 /mnt
    mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so



    # dmesg | tail
    sdb: sdb1
    SCSI device sdb: 490350672 512-byte hdwr sectors (251060 MB)
    sdb: Write Protect is off
    sdb: Mode Sense: 00 3a 00 00
    SCSI device sdb: drive cache: write back
    sdb: sdb1
    VFS: Can't find ext3 filesystem on dev sdb1.


    So at this point i believe the 2nd drive did not get formatted properly. Here is the displayed log during the format/mount operation:

    p primary partition (1-4)
    Partition number (1-4): Partition 1 is already defined. Delete it before re-adding it.


    Command (m for help): Command (m for help): +: unknown command
    Command action
    a toggle a bootable flag
    b edit bsd disklabel
    c toggle the dos compatibility flag
    d delete a partition
    l list known partition types
    m print this menu
    n add a new partition
    o create a new empty DOS partition table
    p print the partition table
    q quit without saving changes
    s create a new empty Sun disklabel
    t change a partition's system id
    u change display/entry units
    v verify the partition table
    w write table to disk and exit
    x extra functionality (experts only)


    Command (m for help): The partition table has been altered!


    Calling ioctl() to re-read partition table.
    Syncing disks.
    Partitioned sdb
    tune2fs 1.39 (29-May-2006)
    Formatted sdb
    Mounted sdb


    Turning Quotas on for the new drive


    Linux Quota Support
    Quotas are now on
    Warning : Your system does not have a separate filesystem for backups. This may cause performance degradation during the backup process.
    /dev/sdb1 (enabling quotas)
    Updating Quota Files......
    quotacheck: Scanning /dev/mapper/SysVolGroup-LogVolRoot [/]
    ...
    quotacheck: Checked 36743 directories and 357767 files
    quotacheck: Can't create new quotafile //aquota.user.new: File exists
    quotacheck: Cannot initialize IO on new quotafile: File exists
    done



    quotacheck: Scanning /dev/mapper/SysVolGroup-LogVolRoot [/]
    ....
    quotacheck: Checked 36742 directories and 357765 files
    done

    ....Done
    PROCESS COMPLETE


    Can someone please help and tell me how to correct this?


    Thank you!
     
  2. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    407
    Likes Received:
    3
    Trophy Points:
    143
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Run the following commands as root via SSH.

    #mkfs.ext3 /dev/sdb1 - this will format sdb1 with ext3 FS

    When it completes, try to mount the drive using

    mount /dev/sdb1 /mnt

    Post the results back here!

    Thank you,
    Nibin.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    407
    Likes Received:
    3
    Trophy Points:
    143
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    If your OS supports ext4, I recoemmend you to try ext4 instead.

    #mkfs.ext4 /dev/sdb1
    #tune2fs -m 0 /dev/sdb1 - this will ensure the reserved space is et to 0%
    #mount /dev/sdb1 /mnt

    Thank you,
    Nibin.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. ronald.prism

    ronald.prism Member

    Joined:
    Dec 26, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Website Owner
    That worked. Thank you.

    Unfortunately the installed OS does not support ext4.


    Best,
    Ronald
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice