The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FormMail getting 'The connection was reset'

Discussion in 'E-mail Discussions' started by arvin1844, Dec 20, 2013.

  1. arvin1844

    arvin1844 Member

    Joined:
    Feb 4, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello Guys,

    I have a formmail script which is working well. But after few hours it will have error when we submit information to the html form. For fixing this I have to run /scripts/restartsrv_httpd . There is nothing on apache error log.

    Apache/2.2.22
    PHP 5.3.27
    Available handlers: suphp dso fcgi cgi none
    DEFAULT PHP: 5
    PHP4 SAPI: none
    PHP5 SAPI: suphp
    SUEXEC: enabled
    RUID2: not installed

    It is a html form which has the action to formmail.pl in cgi-bin directory. Please not that it is working for few hours. After I am getting 'The connection was reset' in Firefox and then I have to run /scripts/restartsrv_httpd for fixing this.

    Any ideas why?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you run EasyApache to ensure you are using the most recent version of Apache available? It shows version 2.2.22 whereas version 2.2.26 is available. Also, are you positive there are no entries in /usr/local/apache/logs/error_log regarding this issue?

    Thank you.
     
  3. arvin1844

    arvin1844 Member

    Joined:
    Feb 4, 2012
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,

    Yes, its sure that there is nothing on apache error log. Are you sure that we need upgrade apache to 2.2.26 for fixing this?




     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I found a similar instance of this issue and running EasyApache resolved the problem. However, more likely, there are some custom settings or restrictions you have in-place that is resetting the connection. You are welcome to submit a support ticket and have us take a closer look. Post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page