The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FormMail not working with method="POST"

Discussion in 'E-mail Discussions' started by hicom, Feb 15, 2004.

  1. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    This is happening on my FreeBSD box, running the latest cPanel v 8.8

    When making any form with any type, and pushing the submit button, it doesn't work unless I put <FORM method="GET"

    The problem with the GET method, it can't handle large forms. One of my clients already complained about his forms break using GET method

    I've had this problem since I got the server installed with cPanel, I worked around it in the past by removing cPanel FormMail and installing Matt's FormMail, but it is pain in the a$$ because i've to add the domains manually!!

    How can I resolve this problem ?? cPanel overwritten my old FormMail files when upgraded to v 8.8

    any help is appreciated
     
    #1 hicom, Feb 15, 2004
    Last edited: Feb 15, 2004
  2. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    resolution

    I found out the resolution to this problem

    You can't use the FQD in the action="" line

    so action="http://www.domain.com/cgi-sys/FormMail.pl"
    will not work using POST method

    you need to use;

    action="/cgi-sys/FormMail.pl"

    only for it to work using the POST method. At least this is the case on my server, any opinions ??
     
Loading...

Share This Page