The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Forward to Gmail - Connection Timeout

Discussion in 'E-mail Discussions' started by alinford, Mar 30, 2017.

Tags:
  1. alinford

    alinford Well-Known Member

    Joined:
    Nov 4, 2006
    Messages:
    54
    Likes Received:
    2
    Trophy Points:
    158
    After the update to 64, email forwarding to gmail accounts stopped working.
    This same thing happened about a month ago after an update, but a few days later, you updated again, and fixed it.

    The server connects to google:
    Connecting to gmail-smtp-in.l.google.com [74.125.70.27]:25 ... connected

    But then it just sits and spins for 30 minutes, before finally Timing Out:
    (110): Connection timed out H=alt4.gmail-smtp-in.l.google.com [209.85.202.27]: SMTP timeout after end of data (138195 bytes written)
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,086
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. alinford

    alinford Well-Known Member

    Joined:
    Nov 4, 2006
    Messages:
    54
    Likes Received:
    2
    Trophy Points:
    158
    I created a ticket.

    Support Request ID is: 8344723
     
  4. alinford

    alinford Well-Known Member

    Joined:
    Nov 4, 2006
    Messages:
    54
    Likes Received:
    2
    Trophy Points:
    158
    cPanel Support was able to figure this out:

    The following bug in Exim was not adding a final newline to messages using BDAT:
    Bug 1974 – Handle missing final CRLF in chunked/BDAT transferred messages, resulting in a missing final LF in spool files
    In cPanel 62 chunking was disabled as a workaround for this bug, however, I'm not seeing in your server's Exim configuration chunking being disabled. I have opened an internal case CPANEL-12403 for this and as a workaround in the mean time I have disabled chunking through Exim's Advanced Configuration Editor.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,086
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, Exim 4.89 was included in cPanel 64 with chunking enabled again, however the Exim changes were not sufficient and still lead to issues like the one reported in this thread. We're disabling chunking again (CPANEL-12403) to address this issue. I'll update this thread again once the change is published.

    Thank you.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,086
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Exim was updated to revert chunking support in a recent cPanel 64 build. Here's an example of the output you should see when checking to confirm that chunking support is disabled:

    Code:
    # cat /usr/local/cpanel/version
    11.64.0.11
    # grep -i chunking /etc/exim.conf
    chunking_advertise_hosts = 198.51.100.1
      hosts_try_chunking = 198.51.100.1
      hosts_try_chunking = 198.51.100.1
    This should address the issue reported on this thread.

    Thank you.
     
Loading...

Share This Page