The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forwarded Email SPF records softfail

Discussion in 'E-mail Discussions' started by inspyre, Jun 18, 2014.

  1. inspyre

    inspyre Member

    Joined:
    Jul 20, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hi there,

    One of our customers has their email forwarding from sales@theirdomain.co.nz to their gmail address, however Gmail keeps putting all forwarded email into the Spam folder.

    After much digging to see if we're on any blacklists and to make sure that the SPF and DKIM records had been set up properly, I've finally found the issue. Google is comparing the SPF records for the original email sender's address to our server's IP, and obviously not finding a match so returning a softfail.

    My questions is - what can we do in cPanel to stop Google from getting this softfail?

    here's the relevant portion of the email headers from Gmail:
    Code:
    [HR][/HR]
    Delivered-To: [email]our.customer@gmail.com[/email]
    Received: by xx.xxx.xx.xxx with SMTP id xxxxx;
            Tue, 17 Jun 2014 21:57:55 -0700 (PDT)
    X-Received: by xx.xx.xx.xx with SMTP id xxxxx;
            Tue, 17 Jun 2014 21:57:55 -0700 (PDT)
    Return-Path: <sender@sender.co.nz>
    Received: from ourserver.ouraddress.co.nz (ourserver.ouraddress.co.nz. [xxx.xxx.xxx.xxx])
            by mx.google.com with ESMTPS id xxxxx
            for <our.customer@gmail.com>
            (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
            Tue, 17 Jun 2014 21:57:55 -0700 (PDT)
    Received-SPF: softfail (google.com: domain of transitioning [email]sender@sender.co.nz[/email] does not designate xxx.xxx.xxx.xxx as permitted sender) client-ip=xxx.xxx.xxx.xxx;
    Authentication-Results: mx.google.com;
           spf=softfail (google.com: domain of transitioning [email]sender@sender.co.nz[/email] does not designate xxx.xxx.xxx.xxx as permitted sender) smtp.mail=sender@sender.co.nz
    [HR][/HR]
    Thanks for your help!

    - - - Updated - - -

    (We have also set up all email addresses, e.g. sales@ourcustomer.co.nz, in Gmail as additional addresses, so Google knows that these addresses belong to the customer, and they are able to send email "from" these addys)
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. inspyre

    inspyre Member

    Joined:
    Jul 20, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hi Michael,

    Thanks very much for getting back to me :) - though maybe I didn't quite explain our problem well enough?

    Our customer can send emails fine, we're having a problem with the emails that they're receiving (when they've been forwarded via cPanel to their Gmail). So if john@example.com emails Joan (our customer) at sales@ourcustomer.co.nz, cPanel is forwarding the email to joan@gmail.com, and Gmail is trying to see if our server is a permitted sender for john@example.com.

    We obviously can't add SPF records to all possible domains that could be sending email to our customer, as those are infinite, so is there anything that can be done in the email forwarding process so that Google doesn't keep marking all forwarded email as spam?

    Cheers, and thanks for your help!
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    That's actually one of the purposes of SPF checking, to limit IP addresses that are allowed to send email from a certain domain name. It looks like Google is reporting the softfail, so it's not blocking the message completely. You may need to contact them directly to see if there is anything you can do, as it's their policy that's putting the messages in the SPAM folder in GMail.

    Thank you.
     
  5. inspyre

    inspyre Member

    Joined:
    Jul 20, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Michael,

    So there's nothing that can be done at the cPanel end? For example, when forwarding emails, changing the headers so that the email is sent from the cPanel account (account@hostname.ourserver.co.nz) with a reply-to address of the original sender? (i.e. resending the email instead of a plain message forward)?

    It seems to me that if Gmail is showing this behaviour with forwarded emails, then it is quite likely that other email systems will too. I understand and agree with you about SPF being used to limit IP addresses and that's a great thing for anti-spam, but forwarding emails is a legitimate procedure and shouldn't be flagged like this, so maybe cPanel should look at the forwarding method it uses and consider how it could be improved to prevent this happening? Because I know that our customers aren't the only ones who will be forwarding their business emails from cPanel to another email system.

    Thanks very much for your time - really appreciate it :)
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You might be able to implement a custom filter rule or a custom Exim ACL to handle these types of forwards, but there are no native options available that I am aware of. Feel free to submit a feature request for this functionality via:

    Submit A Feature Request

    Thank you.
     
Loading...

Share This Page