forwarded mail not filtered by SpamAssassin (Cpanel 11)

jamesbond

Well-Known Member
Oct 9, 2002
738
1
168
I (finally) upgraded to Cpanel 11 today. All went fine, except for one thing.

I have several forwarders set up on different domains which forward to my mail account on my main domain (all domains reside on the same server). I noticed mail coming through those different domains are not filtered by SpamAssassin anymore.

So for example:

SpamAssassin is enabled on domain1.com, it is not enabled on domain2.com or domain3.com

Forwarders:
[email protected] -> [email protected]
[email protected] -> [email protected]

The mail coming in on [email protected] through [email protected] or [email protected] is not being filtered by SpamAssassin. Up till Cpanel 10 I didn't have this issue.

Has something changed here?
 
Last edited:

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
I (finally) upgraded to Cpanel 11 today. All went fine, except for one thing.

I have several forwarders set up on different domains which forward to my mail account on my main domain (all domains reside on the same server). I noticed mail coming through those different domains are not filtered by SpamAssassin anymore.

So for example:

SpamAssassin is enabled on domain1.com, it is not enabled on domain2.com or domain3.com

Forwarders:
[email protected] -> [email protected]
[email protected] -> [email protected]

The mail coming in on [email protected] through [email protected] or [email protected] is not being filtered by SpamAssassin. Up till Cpanel 10 I didn't have this issue.

Has something changed here?
In cPanel 11, the implementation of SpamAssassin changed from a transport-based system to an ACL-based system to be more efficient. As a result, mail sent to an account on the same server is not scanned by SpamAssassin (SA).

External Server -> domain3, domain3 has SA disabled so the mail is not scanned for spam
domain3 -> domain1 (same server), since same server, the mail is not scanned for spam

You can re-enable the old transport system by going to WHM -> Service Configuration -> Exim Configuration Editor.
 

jamesbond

Well-Known Member
Oct 9, 2002
738
1
168
Thanks for the explanation David. Not sure I want to go back to the old configuration. Apart from this issue, I prefer the new setup.

Would simply enabling SA on the other domains (with the forwarders) solve the issue?
Or would I have to set up a pop-account along with each forwarder, in order to have SA scan the incoming mail?
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Thanks for the explanation David. Not sure I want to go back to the old configuration. Apart from this issue, I prefer the new setup.

Would simply enabling SA on the other domains (with the forwarders) solve the issue?
Or would I have to set up a pop-account along with each forwarder, in order to have SA scan the incoming mail?
I believe setting up SpamAssassin on the domain that initially receives the email should resolve the particular issue you are experiencing.