The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

forwarders not working for google app emails

Discussion in 'E-mail Discussions' started by Monstro1409, Apr 6, 2015.

  1. Monstro1409

    Monstro1409 Registered

    Joined:
    Apr 6, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mexico
    cPanel Access Level:
    Website Owner
    hi, well my problem is i have a primary domain mydomain.mx and a parked domain mydomain.com.mx and i was forwarding 3 emails from mail@mydomain.com.mx to mail.mydomain.mx that is linked to google apps. all was working has intented but my server provider migrate the server to a new one and the forwarders stop working, but only the forwarders that send to a google apps email i have tried to forward from both .com.mx and .mx to a normal gmail account and works correctly even if i forward from .com.mx to a non google apps .mx and then to a normal gmail. The server admin said first that maybe a spamhaus problem since was black listed but now is not blacklsited and i still have the same problem, the server admin there is not a problem at their end and offer me a terminate and recreate account but i dont know if when he restore the full account backup the problem will still be in place. Any idea what can i do? what can i tell him to do?
     
  2. danrussell

    danrussell Well-Known Member

    Joined:
    Nov 5, 2014
    Messages:
    60
    Likes Received:
    3
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi :),

    Get the mail logs from your hosting provider for the Forwarded emails from .mx to .com.mx, then can make sure if its getting sent from the server to Google.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you have your provider review /var/log/exim_mainlog when the delivery fails to verify the exact reason for the failure?

    Thank you.
     
  4. Simone Ramella

    Simone Ramella Registered

    Joined:
    Aug 5, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Italy
    cPanel Access Level:
    Website Owner
    It's been some months since this thread was started and hopefully Monstro1409 found a fix for this problem. I landed here for I had exactly the same issue with my cPanel not forwarding anymore to my Google Apps email right after a server migration. For those out there running into the same problem, after some talking with my hosting provider customer assistance and the Gmail support staff, all very kind and supportive, a technical operator at KnownHost pointed out that my Google Apps domain was configured for local delivery on my VPS.

    Indeed, cPanel occasionally fails to correctly detect when a domain has remote mail exchangers when building the MTA configuration, and that appears to have happened in my case. So the KnownHost operator explicitly set the domain to have a remote mail exchanger, under WHM->Home->DNS Functions->Edit DNS Zone->mydomain.com and my cPanel mail forwarding started working again as expected.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page