Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Forwarding email to /dev/null, but it still goes to catch-all

Discussion in 'E-mail Discussion' started by dotancohen, Aug 18, 2007.

  1. dotancohen

    dotancohen Member

    Joined:
    Aug 18, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    Haifa
    As some spammer is sending email with a From address at my domain, I have been receiving thousands of bounced emails. Some of the more popular addresses I have sent to /dev/null via forwarders. However, mail to these addresses still gets received in my catch-all. Why? How do I fix that?

    Note that I've tried E-mail Filtering as well, but it does not work. If I configure, for instance, "$header_to: is someAddress@example.com" then mail delivered to "Some Person <someAddress@example.com>" gets through. And using "$message_headers contains someAddress@example.com" does not work for addresses that are part of addresses that I need to keep. For instance, I cannot trap "otan@example.com" while keeping "dotan@example.com". And otan@example.com gets a _lot_ of spam.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Rather than using /dev/null try setting up a forwarder for the email address and pointing it to :fail: - the email should then not be received by the server at all.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dotancohen

    dotancohen Member

    Joined:
    Aug 18, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    Haifa
    Thanks, I'll give that a try.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. dotancohen

    dotancohen Member

    Joined:
    Aug 18, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    Haifa
    Thank you, it the :fail: option effectively blocks the addresses. It has been several days and no messages have gotten through.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice