The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

forwarding mail to another server problem

Discussion in 'E-mail Discussions' started by floridaguy, Nov 26, 2003.

  1. floridaguy

    floridaguy Member

    Joined:
    Apr 2, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I've searched the forum and can't seem to find the answer to this.

    I have a user with a domain, lets say customer.com.
    He runs his own exchange server which all mail is forwarded to. This all works fine for mail generated outside of my server. Any mail from INSIDE my server, such as from me or from his OSCommerce install, doesn't get forwarded off the server to his exchange server. Rather, it sits in the users mailbox on my server.

    Can someone tell me how to resolve this?

    Thank you in advance,
    Floridaguy
     
  2. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    Well, this should be easy to fix. First where is the DNS for his domain hosted and what do the MX records say?
    Then is the domain in question in your /etc/localdomains file?
    I will wait for your answers to go further than that.
     
  3. floridaguy

    floridaguy Member

    Joined:
    Apr 2, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Cyber, Thank you for replying.

    The DNS is hosted on my machine (same one as site is on).
    The mx record shows this:

    MX Record: customer.com. 14400 IN MX 0 exchange01.customer.com.
    A Record: exchange01.customer.com. 14400 IN A 209.241.100.100

    This assumes his exchange server is named exchange01 and sits on the internet at 209.241.100.100

    The domain IS listed in the localdomains file, right in line with all of the other domains on the server.

    Thanks
    Floridaguy
     
  4. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    well, take the domain out of /etc/localdomains and put it into /etc/secondarymx and it should work.
     
  5. floridaguy

    floridaguy Member

    Joined:
    Apr 2, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Cyber,

    Thanks.
    Will this fix stay, or will Cpanel write over it often and I'll have to re-do?

    Floridaguy
     
Loading...

Share This Page