The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forwarding root mail, but not receiving it.

Discussion in 'E-mail Discussions' started by kemis, Feb 18, 2006.

  1. kemis

    kemis Well-Known Member

    Joined:
    Feb 17, 2005
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Georgetown, TX
    This may be a newbie setup/config problem, but here goes:

    -- Mail to root is currently being forwarded to something@domain.com via WHM (also viewable in root's .forward file).
    -- Sending a logwatch report to something@domain.com works
    -- Sending a logwatch report to root never gets anything into the forwarded mailbox

    Considering I haven't received anything else in my forwarded root mailbox after two weeks of running my VPS (or nobody, or cpanel, either), it makes me think there's some check box I need to change somewhere?

    Please help,
    Matt
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You would have to check your exim mainlog (/var/log/exim_mainlog) from when the email was sent for messages/errors.
     
  3. kemis

    kemis Well-Known Member

    Joined:
    Feb 17, 2005
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Georgetown, TX
    Well, crap. I don't understand the results. Here's what pops up in my exim_mainlog after sending a mail to simply "root":

    Code:
    1FAs9j-0005Xk-OX <= root@server.example.com U=root P=local S=4024
    1FAs9j-0005Xk-OX lowest numbered MX record points to local host: server.example.com
    1FAs9j-0005Xk-OX == root@server.example.com R=lookuphost defer (-1): lowest numbered MX record points to local host
    1FAs9j-0005Xk-OX ** root@server.example.com: retry timeout exceeded
    1FAsA1-0008Nl-O3 <= <> R=1FAs9j-0005Xk-OX U=mailnull P=local S=4883
    1FAs9j-0005Xk-OX Completed
    1FAsA1-0008Nl-O3 lowest numbered MX record points to local host: server.example.com
    1FAsA1-0008Nl-O3 == root@server.example.com R=lookuphost defer (-1): lowest numbered MX record points to local host
    1FAsA1-0008Nl-O3 ** root@server.example.com: retry timeout exceeded
    1FAsA1-0008Nl-O3 root@server.example.com: error ignored
    1FAsA1-0008Nl-O3 Completed
    Stumped,
    Matt
     
  4. kemis

    kemis Well-Known Member

    Joined:
    Feb 17, 2005
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Georgetown, TX
    Fixed it.

    Turns out that I needed to add "server.mydomain.com" to the /etc/localdomains file and restart exim.

    This is obviously a cPanel bug, then, because I shouldn't have to do this. If I go to "Change System Mail Preferences" in WHM and enter in the forwarding addresses for root, cpanel, & nobody, then cPanel should ensure the necessary entries are made in the localdomains file (or else that entry should be made by cPanel beforehand when it is first installed on the server).

    Anyway, problem solved. Hopefully this helps anyone else stuck in this dilemma.

    -- Matt
     
Loading...

Share This Page