The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

forwarding the ip url for whm to the hostname

Discussion in 'General Discussion' started by durangod, Aug 8, 2014.

  1. durangod

    durangod Well-Known Member

    Joined:
    May 12, 2012
    Messages:
    251
    Likes Received:
    10
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    Since i now have my host name ssl cert, i would like to forward my ip url to the host name url, is that doable. The reason is that the ip is not covered under my cert and it bugs me to see the warning when loggin in. Also i want my login and session activity covered under my ssl.


    So for example can i per forward this

    https://xxx.xxx.xxx.xxx:2087/ the link to the login and also this after i am logged in https://xxx.xxx.xxx.xxx:2087/cpsesxxxxxxxxxx887/

    to this

    https://hostname.domain.com:2087/

    https://hostname.domain.com:2087/cpsesxxxxxxxxx887/


    and still maintain the same security and access that i have with the ip?

    if so whats the best way to do that or what is the doc that covers how to do that?

    is there a downside to this?

    i have tested accessing with this https://hostname.domain.com:2087/
    and it does seem to work. Im just not sure what the process or ups and downs are.

    as of yet i have not seen anything pertaining to host level in http://docs.cpanel.net/twiki/bin/view/11_30/WHMDocs/TweakSettings#Redirection, it talks about users cpanels but not the root.
     
    #1 durangod, Aug 8, 2014
    Last edited by a moderator: Aug 8, 2014
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Please use the new docs site. Not sure it matters here for this, but just a reminder for you all the same.
    Tweak Settings - Redirection - cPanel Documentation

    Change it. That's the easy answer. Is there a reason you cannot?

    Using self signed certs (in a default cPanel setup) is not exactly unsafe. You can accept the cert into your browser (or add an exception depending on the browser) properly to get rid of the warning. Not what you're doing of course, just mentioning it.
     
  3. durangod

    durangod Well-Known Member

    Joined:
    May 12, 2012
    Messages:
    251
    Likes Received:
    10
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    Thank you,

    Yes the reason i didnt assign the url to the cert as well is because that can change, if we have issues for some reason and i didnt want to have to buy another cert or a wildcard with is very expensive in order to cover it all.

    I tried adding it to my IE11 but it would not even let me do the exception, FF and Chrome gave me that option but IE11 did not.

    Are you saying that i can add the ip from my end to the cert, and then change that data if we change ip's, i was not aware of that.

    - - - Updated - - -

    also i did test all the option in that doc section last night, i set it each way and tested it.. Some worked better than others, and some were not an option at all. The best that works for me is to have the first one set, always redirect to ssl which works for everything other than the ip for root..

    - - - Updated - - -

    so the ideal way for me to do this last little part of the process is just to set up a forward from the ip to the host name, or add the ip to the cert.

    - - - Updated - - -

    and i do admit i always get confused which is the new doc site and which is the old lol.
     
  4. durangod

    durangod Well-Known Member

    Joined:
    May 12, 2012
    Messages:
    251
    Likes Received:
    10
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    lol i suppose i could just change the url on my desktop icon couldnt i lol..... :)
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Your concern is misplaced I think. Sure something can happen issues can come up, but that's what you should do anyway.

    Adding a cert properly to IE is a bit different. Forget any shortcut icons on your desktop, find the IE icon on the start menu and right click, choose "Run as Administrator".
    Type in your domain name to address bar: domain.com/cpanel and go.
    Click cancel on the popup for login.
    Click Certificate error to right of address bar.
    Click View Certificate.
    Click Install Certificate.
    Click Next, select "Place all certificates in the following store"
    Click Browse.
    Select "Trusted Root Certification Authorities"
    Click Next.
    Click Finish.
    Read Warning, click Yes.
    "The Import Was Successful"
    Click OK.
    Click OK on Certificate window to close.
    Close browser. Reopen browser not in Admin mode.
    Go to: domain.com/cpanel and note red warning is now not displayed.


    Proper settings there are:
    Always redirect to SSL - Yes
    Non-SSL redirect destination - hostname
    SSL redirect destination - SSL Certificate Name
    Logout redirection URL - Your website, your forums, your ticket system, mtv.com even. Whereever you like, or:
    No redirection default

    domain.com/cpanel for cPanel access.
    domain.com/whm for WHM access.

    Typing either into your address bar, is your shortcut. Both will now send you to:
    server.domain.com:2083 or :2087

    Once you get there, at either address, feel free to right click the page and click Create Shortcut, to add new shortcuts to your desktop or bookmarks.
     
  6. durangod

    durangod Well-Known Member

    Joined:
    May 12, 2012
    Messages:
    251
    Likes Received:
    10
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    Thanks :) i will try this when i wake up, for some reason i am not getting my notifications on replies, i checked my email and my profile settings and they are all ok and i added cpanel to my whitelist. So if i dont reply to something please foregive me, i will in time. :)
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Your subscription to this thread specifically, is set to only receive notifications thru your control panel, here:
    /http://forums.cpanel.net/subscription.php?folderid=0

    You change your forum wide subscription settings, here:
    /http://forums.cpanel.net/profile.php?do=editoptions
    "Default Thread Subscription Mode:"

    Set it to Instantly.

    Nighty night. ;)
     
  8. durangod

    durangod Well-Known Member

    Joined:
    May 12, 2012
    Messages:
    251
    Likes Received:
    10
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    oh oh oh dag nabbit lol... ok will do..

    the issue with this

    is that if you choose the first one (enable it) the others go away, so unless the first one is off, you cant set the others. So which is more important? Setting them individual or enable the first one.
     
  9. durangod

    durangod Well-Known Member

    Joined:
    May 12, 2012
    Messages:
    251
    Likes Received:
    10
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    how strange it was set to instantly, i reset it and saved it again
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Enable them as you wish, and then tick the top one, last, if you wish. ;)
     
Loading...

Share This Page