Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Found 4 pre-existing rpmdb problems

Discussion in 'CloudLinux' started by azn_romeo_4u, Jun 3, 2016.

Tags:
  1. azn_romeo_4u

    azn_romeo_4u Active Member

    Joined:
    Jun 1, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    156
    Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
    Code:
    
    Error: Package: alt-php52-snmp-5.2.17-81.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: libnetsnmp.so.31()(64bit)
    Error: Package: alt-php51-snmp-5.1.6-54.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: libnetsnmp.so.31()(64bit)
    Error: Package: 1:alt-php55-snmp-5.5.36-1.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: libnetsnmp.so.31()(64bit)
    Error: Package: 1:alt-php55-snmp-5.5.36-1.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: net-snmp
    Error: Package: alt-php44-snmp-4.4.9-48.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: net-snmp
    Error: Package: alt-php53-snmp-5.3.29-31.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: libnetsnmp.so.31()(64bit)
    Error: Package: alt-php70-snmp-7.0.7-1.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: libnetsnmp.so.31()(64bit)
    Error: Package: alt-php44-snmp-4.4.9-48.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: libnetsnmp.so.31()(64bit)
    Error: Package: alt-php53-snmp-5.3.29-31.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: net-snmp
    Error: Package: alt-php51-snmp-5.1.6-54.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: net-snmp
    Error: Package: alt-php70-snmp-7.0.7-1.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: net-snmp
    Error: Package: alt-php56-snmp-5.6.22-1.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: libnetsnmp.so.31()(64bit)
    Error: Package: alt-php54-snmp-5.4.45-16.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: libnetsnmp.so.31()(64bit)
    Error: Package: alt-php56-snmp-5.6.22-1.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: net-snmp
    Error: Package: alt-php52-snmp-5.2.17-81.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: net-snmp
    Error: Package: alt-php54-snmp-5.4.45-16.el7.x86_64 (cloudlinux-x86_64-server-7)
               Requires: net-snmp
    You could try using --skip-broken to work around the problem
    ** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
    MariaDB-server-5.2.10-107.el5.x86_64 has missing requires of libmysqlclient.so.16()(64bit)
    MariaDB-server-5.2.10-107.el5.x86_64 has missing requires of libmysqlclient.so.16(libmysqlclient_16)(64bit)
    MariaDB-server-5.2.10-107.el5.x86_64 has missing requires of libmysqlclient_r.so.16()(64bit)
    MariaDB-server-5.2.10-107.el5.x86_64 has missing requires of libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
    
    This shows up when I try to install phpselector "yum groupinstall alt-php"
     
    #1 azn_romeo_4u, Jun 3, 2016
    Last edited by a moderator: Jun 3, 2016
  2. twhiting9275

    twhiting9275 Well-Known Member

    Joined:
    Sep 26, 2002
    Messages:
    555
    Likes Received:
    16
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Twitter:
    Try
    Code:
    yum -y install net-snmp
    
    Then retry groupinstall

    Also, it'd be good to post this in the appropriate forums. This isn't directly a cPanel issue, but a cloudlinux one. They're two different beasts
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #2 twhiting9275, Jun 3, 2016
    Last edited by a moderator: Jun 3, 2016
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,344
    Likes Received:
    1,852
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    As mentioned, you can try installing the missing packages through YUM and then run the "yum update" command again to see if the issue persists.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice