fpfakeout.so error creating acct on Freebsd

nyjimbo

Well-Known Member
Jan 25, 2003
1,135
1
168
New York
After upgrading to E247 on a Freebsd 4.7 box we noticed when creating new accounts with FP extensions an error would come up:

" Warning, fpfakeout.so failed to build. Please discover the reason!"

This is during the frontpage part of creating the account.

After creating it the new customer gets weird "closed connection" errors on publishing using frontpage with the http publish mode.

Anyone see this before ?
 

datawebcorp

Member
Jun 23, 2005
6
0
151
I just had CPanel insalled, today. I am having the same fpfakeout.so error. Is this my build number: 10.6.0-R55? If so, do I have the latest?

Finally, can I keep going even w/this error? Will the sites I create work?
 

jensendw

Member
Aug 7, 2005
8
0
151
I havn't been using Cpanel for long, but when it will be fixed in the next release what kind of time frame are we looking at, also does anyone have a tempoary fix?
 

datawebcorp

Member
Jun 23, 2005
6
0
151
I opened a support ticket and apparently they're going to connect to my server and fix it. SO I guess there is a fix.

I'll let you know how it goes.
 

adapter

Well-Known Member
PartnerNOC
Sep 17, 2003
391
0
166
same porblem for me today

Warning, fpfakeout.so failed to build. Please discover the reason!

thank you
 

hatch

Registered
Apr 30, 2003
4
0
151
I had the same problem, and i fixed it by running this as root:

Code:
gcc -Wall -O2 --shared -o /scripts/fpfakeout.so /scripts/fpfakeout.c

Regards

Kim Andersen
DGroup
 

visualfast

Registered
Aug 26, 2005
2
0
151
Hello
i m getting the same error "Using Frontpage 5.x!
Warning, fpfakeout.so failed to build. Please discover the reason!
No such file or directory "
any help i run this command through root "gcc -Wall -O2 --shared -o /scripts/fpfakeout.so /scripts/fpfakeout.c"
and this error appears "/usr/bin/ld: /tmp/ccUMHAdU.o: relocation R_X86_64_32 can not be used when making a shared object; recompile with -fPIC
/tmp/ccUMHAdU.o: could not read symbols: Bad value
collect2: ld returned 1 exit status"
Kindly inform me solution
thanks
From
Kamran Iqbal
 

datawebcorp

Member
Jun 23, 2005
6
0
151
I had the folks at CPanel connect to my server to resolve the problem. Here's what they said: "I've installed the glibc-devel-2.3.2-95.33.i386.rpm rpm on your server...".

That solved the problem for me.
 

dan_c

Active Member
Jul 23, 2005
39
0
156
I am getting this message on a CentOS machine that is brand new from the datacenter. What might be causing this?
 

arkain

Well-Known Member
Mar 20, 2003
93
0
156
will this also cause new accounts not being able to registerered to the DNS? I've created over 20 accounts, and none of them are responding...
 

liwiplus

Member
Jul 22, 2006
17
0
151
Hi,

This is only an intermediate fix.... copy the missing so file fpfakeout.so from the server where it has installed. I did that and it is working fine even ldd is taking it correctly:

ldd fpfakeout.so
libdl.so.2 => /lib/libdl.so.2 (0x40012000)
libc.so.6 => /lib/libc.so.6 (0x40016000)
/lib/ld-linux.so.2 (0x41000000)