FREE ASSP X (ASSP eXtended - WHM addon with cPanel interface)

Status
Not open for further replies.

ispro

Well-Known Member
Verifed Vendor
Apr 8, 2004
628
2
168
Updated ASSP X to 2.2.2 version to include the fix of local emails generation script as well as few small typos.

New ASSP daemon version is work in progress. Enjoy!
 

m0rpheu5

Well-Known Member
Jun 16, 2005
75
0
156
Brazil, Curitiba/PR
cPanel Access Level
Root Administrator
I´m using the ASSP X 2.2.2, it really works, but i don´t know why sometimes it loose the configuration that i set on them, like whitelisted IP´s, whitelisted domains, Penaltybox Score, and Size of Header Messages, i would like to know what have i do to fix this? i done this changes from ASSP Web Interface, and then i click on Apply Changes, have i do anything else??

Another Doubt that i have is, many email that i receive (SPAM and Not Spam) on the mail properties i saw "X-Assp-Message/IP-Score: 18.5" but if i change the Penalty Box to block everything more then Score 18, i stop to receive many emails that was not spam, how can i do with that?

Thanks
 

ispro

Well-Known Member
Verifed Vendor
Apr 8, 2004
628
2
168
1) It is not so clear (argh, lack of documentation!), but for such changes you need to use ASSP X override ability. E.g. create directory (if not exists) /etc/asspx/files.append/ and /etc/asspx/rules.append/ and place there necessary ADDITIONS for respective files in /usr/local/assp/files/ and /usr/local/assp/rules/
If you need to have completely fresh file, use directories /etc/asspx/files/ and /etc/asspx/rules/
What about assp.cfg overrides, use file /etc/asspx/assp.cfg (it should already have some basic overrides like hashed password, etc.). When you place variable there it will be used instead of default.

To apply changes run once /usr/local/assp/scripts/asspxpatch

2) You just have set it too low. Even not spam message may receive some scoring, it is the way scoring works and that's why there are thresholds.
 

m0rpheu5

Well-Known Member
Jun 16, 2005
75
0
156
Brazil, Curitiba/PR
cPanel Access Level
Root Administrator
Hello guys, i´m getting another problem with some sites that send emails to my clients, i create a test account, and looking into the Mail Log, i get many invalid address rejected or user unknow for valid users, follow a test that i use the WeTransfer, a site that sent big files to email, many clients use it.

Nov-23-12 14:58:12 89891-04110 [InvalidAddress] 216.146.32.156 <[email protected]
mailer.net> invalid address rejected: [email protected]
Nov-23-12 14:58:12 89891-04110 216.146.32.156 <[email protected]>
PB-Message-Score is 25, added 25 (invalid address [email protected])
Nov-23-12 14:58:12 89891-04110 216.146.32.156 <[email protected]>
[SMTP Error] 550 5.1.1 User unknown: [email protected]


What could be?
Thanks
 

ispro

Well-Known Member
Verifed Vendor
Apr 8, 2004
628
2
168
It could be a bug but it may also be the delay between localemails file generation.

If you are still having an error you may contact us via PM/email to investigate it for you (free).
 

besik

Registered
Dec 4, 2013
1
0
1
cPanel Access Level
Root Administrator
Mailman stoped delivering messages!

Hi,

I've server with around 200 clients and some of them are using Mailman mailing list included in cPanel.
I have installed ASSP X anti spam software, but as many clients did complain, I removed it and reactivated spam assassin and box trapper again. (followed your uninstall instruction).
Mails appear started working, but mailing lists have trouble. sending test email to mail list address gives reply to approve sending, etc, but at the end messages are not being delivered.

Sample log from mailman smtp-failure:

-----
Dec 04 23:37:17 2013 (4310) All recipients refused: {'[email protected]': (550, 'Verification failed for <[email protected]>\nUnrouteable address\nSender verify failed')}, msgid: <[email protected]>
Dec 04 23:37:17 2013 (4310) delivery to [email protected] failed with code 550: Verification failed for <[email protected]>
Unrouteable address
Sender verify failed

-----

Everything was working fine before ASSPX installation..

Hope for your help.

Thanks a lot
 

ispro

Well-Known Member
Verifed Vendor
Apr 8, 2004
628
2
168
We have responded via email to you earlier. Despite of that you decided to post on the forums.

The problem you have is not ASSP X related.
 

ispro

Well-Known Member
Verifed Vendor
Apr 8, 2004
628
2
168
We plan to switch to ASSP v2 because v1 announced to reach its EOL in 2015.
Anyway, ASSP and ASSP X is still good choice. We are using ASSP X on all our servers.
 
Status
Not open for further replies.